Lost Admin Password for Solaris

Posted on 2011-03-22
Last Modified: 2012-05-11

I am not sure which version of Solaris I am running but it also has Sun Java 7.0 loaded onto it. I can log into the console with my root logon and password but I loaded Putty on my Windows workstation and it won't take my root logon and password. I enter root and enter the password and it refuses it. I wonder if there is another logon and password I should be using?

This server was given to me so I am trying to figure it out without having to reload it. So, I am curious why my root logon and password will not work when I try to use Putty, I am not sure of the admin url so that I can administor the server via http.

Do you have an idea what I need to do in order to use Putty, and if there is another logon and password I need to use then how can I figure out what may have already been configured?

Question by:jhieb
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +2
LVL 37

Expert Comment

by:Neil Russell
ID: 35192899
Logon with root via ssh/telnet is usually restricted, AS IT SHOULD BE!

Creat a normal user that has SU permissions and connect as that user maybe?
LVL 68

Accepted Solution

woolmilkporc earned 500 total points
ID: 35192907
Seems that the ssh server (sshd) running on the Solaris box does not allow root login due to
PermitRootLogin no
in /etc/ssh/sshd_config.

Obviously we can't tell you what other accounts would exist on that server, but since you have root access you could either create such an account (see "man useradd") or change the setting in sshd_config to permit root login in the future.

Please remember that you must stop and restert sshd for the new sshd_config setting to become effective.


LVL 16

Expert Comment

by:Joseph Gan
ID: 35192928
Putty is on your Windows workstation, Windows dosen't use "root", uses "administrator" or your user id. Ask your Windows administrator to give you an account to logon to Windows, you should be able to use Putty then.
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!


Author Comment

ID: 35193660
Hi Neilsr, I tried to login with SSH/Telnet with Putty but the session still does not accept my logon or password. Thanks for the suggestion.

Expert Comment

ID: 35193661
From the solaris box use the useradd command to create a new user for yourself. Assign it a password with the passwd command. Now you should be able to connect using putty and the new user account you created. To access root level permissions use the su command.

Author Closing Comment

ID: 35193747
This did the trick and I am in as the ROOT account. Thank you.
LVL 37

Expert Comment

by:Neil Russell
ID: 35193853
Well i can see you have accepted the answer that you feel is right BUT remember the consequenses! You have just enables REMOTE ROOT access to your system. You now have a single password between you and your system being exploited.

Like I said in the first post, ROOT access is denied by default for a reason. Its making your system about as insecure as you can get.

Good luck,

At least read the question and understand the topic before you post drivel :P
We know putty is a windows application!! The questioner SAID he is using it to access a solaris system using his root logon and password using putty from windows!!

Author Comment

ID: 35193870
Thanks for the additonal warning, Neilsr. I appreciate it.
LVL 16

Expert Comment

by:Joseph Gan
ID: 35194118
That why I did not get points, so as you :p

Featured Post

Announcing the Most Valuable Experts of 2016

MVEs are more concerned with the satisfaction of those they help than with the considerable points they can earn. They are the types of people you feel privileged to call colleagues. Join us in honoring this amazing group of Experts.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Virtualizing TAPE on dual VIOS 3 125
Unix Question 19 56
How to check the PVU´s on AIX TSM servers? 3 133
centos commands 6 117
Hello fellow BSD lovers, I've created a patch process for patching openjdk6 for BSD (FreeBSD specifically), although I tried to keep all BSD versions in mind when creating my patch. Welcome to OpenJDK6 on BSD First let me start with a little …
FreeBSD on EC2 FreeBSD ( is a robust Unix-like operating system that has been around for many years. FreeBSD is available on Amazon EC2 through Amazon Machine Images (AMIs) provided by FreeBSD developer and security office…
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question