[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1901
  • Last Modified:

vmware view error to log on to this remote computer, you must be granted the Allow logon through Terminal Servers right

Have setup vmware view ...created pool and desktops, given entitlements and my win 7 box give me the error  error "to log on to this remote computer, you must be granted the Allow logon through Terminal Servers right"
Do i do this on the parent vm?  Group Policy?
0
infranetsupport
Asked:
infranetsupport
  • 7
  • 2
1 Solution
 
Hutch_77Commented:
You are using RDP rather than the VMWare to connect to the view connection.  If you change the the VMWare protocol it should let you right in.  Otherwise you have to add rdp rights to users on the pool machines.  The parent permissions will not pull to the children for some reason.  
0
 
Hutch_77Commented:
PCOIP is the protocol that was slipping my mind.  it basically creates a console session.
0
 
Hutch_77Commented:
I added RDP rights using GP and adding groups to RDP on the computer side of GP.  This allows for a configuration that applys to the computer at boot... or Vm in this case.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
ActiveDirectorymanCommented:


Yea you should be using PCOIP. There is no need to use RDP on the client side.  Are you using HP thin client desktops and laptops and then using the vmware view agent on the desktop to connect to the view connection server?  How are you connecting to the view connection server?  Are you using a windows client with vmware view installed on it? or a thin client?  are you using a HP thin pro client with thinpro control center or a HP thin client laptop with windows 7 embedded ?
0
 
Hutch_77Commented:
I do know one thing if you are using the WYSE cloud client gfor mobile devices it says it is using PCOIP but it still uses a piece of RDP as well.
0
 
ActiveDirectorymanCommented:



Yea I agree. On the HP Thin Client pro desktop within the HP thin client control center you select different connection types such as RDP or Vmware view, etc
0
 
Hutch_77Commented:
The Wyse terminals are the same way.. I just wanted to make sure he doesnt have te headache I did making it work with Wyse Pocket cloud on ipads.
0
 
infranetsupportAuthor Commented:
PCoip works fine from inside...this is an outside connection that is using RDP
0
 
Hutch_77Commented:
Then you will need to create a usergroup for users using the RDP sessions
in GPO go to computers side and add the group to a policy applied to the needed machines.  This will add them every time they are booted saving you the headache of redoing it when you refresh or reuild the machines.

I am looking up the exact GPO setting as its been 6 months since I set this up.
0
 
Hutch_77Commented:
  1. Run gpedit.msc to open the Group Policy editor
   2. Navigate to the following location: Local Computer Policy\Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment
   3. Double-click the "Allow logon through Terminal Services" item
   4. Add the account in question to the list of allowed users

There the instructions are.

You can do tis individually or by group.. group just makes manageability easier.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 7
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now