Solved

XAMPP

Posted on 2011-03-22
4
611 Views
Last Modified: 2012-05-11
I installed XAMPP in my Windows7 to run my JOOMLA!

My MySQL is running but when I click in Admin to set my database nothing happens.

How can I fix it?

thanks,
0
Comment
Question by:jr_barros_jr
  • 2
4 Comments
 
LVL 13

Assisted Solution

by:StormITSolutions
StormITSolutions earned 500 total points
ID: 35195275
HI

http://docs.joomla.org/Setting_up_your_workstation_for_Joomla!_development

This has everything you need to setup and troubleshoot your XAMPP

Storm
0
 
LVL 13

Accepted Solution

by:
StormITSolutions earned 500 total points
ID: 35195284
Dont go past Install Eclipse section as this is for developers.

http://www.apachefriends.org/f/viewforum.php?f=16&sid=1d2d2eaacf935d717359da8980fe14e8

THis link also helps as its the main forum users for xampp use many threads and solutions to different troubles.

Storm
0
 

Author Closing Comment

by:jr_barros_jr
ID: 35195448
I am aceppting that to avoid future problem.

I am very disappointed with JOOMLA and XOOMP. They do not work, they are not easy at all to install and there are a lot of extra work to set this up.

Even to a Mac those applications are a garbage.
0
 
LVL 13

Expert Comment

by:joomla_php
ID: 35195609
I didn't see this until it was closed but I have to tell you it's not that hard, there's just one problem. You have to get xampp 08. April 2009 1.7.1 Beta5 to run with Joomla 1.5.22 -- download from oldapps.com here

http://www.oldapps.com/xampp.php?old_xampp=44

Make sure nothing is running on port 80, such as skype

Run the xampp install

Take all of the defaults -- especially when it insists on running from c:/xampp. Use that, not c:/program files.

After xampp installation run xampp control panel, ensure apache and mysql are running

Run phpmyadmin http://localhost/phpmyadmin/

Create a database (for instance, "joomla")

default user is root, no password

unzip joomla 1.5.22 into htdocs (for instance, htdocs/joomla)

In the browser run http://localhost/joomla

Enter database joomla, user root, no password

Take defaults throughout setup.

Delete htdocs/joomla/install

In the browser run http://localhost/joomla and http://localhost/administrator


The reason it's garbage is because joomla 1.5.22 will not run on any xampp higher than 1.7.1, which is PHP version 5.2.9.

Xampp 1.7.2+ have php versions 5.3 and up that break joomla.


0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

In Solr 4.0 it is possible to atomically (or partially) update individual fields in a document. This article will show the operations possible for atomic updating as well as setting up your Solr instance to be able to perform the actions. One major …
Does the idea of dealing with bits scare or confuse you? Does it seem like a waste of time in an age where we all have terabytes of storage? If so, you're missing out on one of the core tools in every professional programmer's toolbox. Learn how to …
Excel styles will make formatting consistent and let you apply and change formatting faster. In this tutorial, you'll learn how to use Excel's built-in styles, how to modify styles, and how to create your own. You'll also learn how to use your custo…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now