XAMPP

I am having the followinfg message when I am running "http://localhost" and clicking in any language link displayed. I already re-install the application three times.

By the way, I am running that from a Mac.

Do not send me links from google based in a simple search from this words. I want answers not links.

Warning: fopen(lang.tmp) [function.fopen]: failed to open stream: Permission denied in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 2

Warning: fwrite() expects parameter 1 to be resource, boolean given in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 3

Warning: fclose() expects parameter 1 to be resource, boolean given in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 4

Warning: Cannot modify header information - headers already sent by (output started at /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php:2) in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 5
jr_barros_jrAsked:
Who is Participating?
 
NickGermiConnect With a Mentor Commented:
I'm not a Mac expert but the have used XAMPP on Windows, the first error XAMPP is reporting seem to be related to file/folder permissions, rest of the errors might be appearing because of the first error

I would try changing the permission on XAMPP installation directory to public read write execute access
0
 
ErnadeJoCommented:
2 years later ;-), I have the same problem. "Changing the permission to public read and write: How and where?"

After installing XAMPP on a Mac I get this message when I'm running localhost:

Warning: fopen(lang.tmp) [function.fopen]: failed to open stream: Permission denied in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 2

Warning: fwrite() expects parameter 1 to be resource, boolean given in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 3

Warning: fclose() expects parameter 1 to be resource, boolean given in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 4

Warning: Cannot modify header information - headers already sent by (output started at /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php:2) in /Applications/XAMPP/xamppfiles/htdocs/xampp/lang.php on line 5
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.