Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Config SWAT for Samba on Fedora 14

Posted on 2011-03-22
11
Medium Priority
?
706 Views
Last Modified: 2012-05-11
Ive followed thid:
http://www.liberiangeek.net/2010/05/how-to-install-swat-on-fedora-linux-and-manage-samba-easily/

SWAT service is running
Firewall is disabled
‘disable’ to no and save the file.

Doesnt work.
What to do?
What to check?

3 am here - can do no more, but look forward to some ideas tomorrow morn.





0
Comment
Question by:fcek
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
11 Comments
 
LVL 31

Expert Comment

by:farzanj
ID: 35195606
Shouldn't it be disable to yes?

Check if the samba service is running.
0
 
LVL 29

Expert Comment

by:fosiul01
ID: 35195643
what is not working ??
0
 

Author Comment

by:fcek
ID: 35197257


"what is not working ?? "This does work:
http://localhost:901

farzanj:Shouldn't it be disable to yes? > it should be set to No according to instructions.
Check if the samba service is running.  > It is running.
0
Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 
LVL 31

Expert Comment

by:farzanj
ID: 35197823
Ok.

Use netstat to see how it is running.

 
netstat -antpu | grep smbd

Open in new window


Show your IP tables entries.
 
iptables -L

Open in new window

0
 

Author Comment

by:fcek
ID: 35200179


Im a n00b but trying my best ...... heres what I got with those commands

[root@server3 ed]# netstat -antpu | grep smbd
[root@server3 ed]# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination        
ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED
ACCEPT     icmp --  anywhere             anywhere            
ACCEPT     all  --  anywhere             anywhere            
ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:ssh
REJECT     all  --  anywhere             anywhere            reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination        
REJECT     all  --  anywhere             anywhere            reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination        
[root@server3 ed]#

0
 
LVL 31

Assisted Solution

by:farzanj
farzanj earned 1000 total points
ID: 35203654
Ok.  I don't see your smbd running at all.

Run the command

netstat -antpu

And try to find samba.  Looks like it is not listening
0
 

Author Comment

by:fcek
ID: 35207837

Hi this is the latest .... still not working. thanks.

[root@server3 ed]# netstat -antpu | grep smbd
tcp        0      0 :::445                      :::*                        LISTEN      30917/smbd          
tcp        0      0 :::139                      :::*                        LISTEN      30917/smbd          
[root@server3 ed]# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination        
ACCEPT     all  --  anywhere             anywhere            state RELATED,ESTABLISHED
ACCEPT     icmp --  anywhere             anywhere            
ACCEPT     all  --  anywhere             anywhere            
ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:ssh
REJECT     all  --  anywhere             anywhere            reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination        
REJECT     all  --  anywhere             anywhere            reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination        
[root@server3 ed]# netstat -antpu
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name  
tcp        0      0 0.0.0.0:46567               0.0.0.0:*                   LISTEN      1164/rpc.statd      
tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      1080/rpcbind        
tcp        0      0 0.0.0.0:22                  0.0.0.0:*                   LISTEN      1368/sshd          
tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN      1231/cupsd          
tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN      2236/sendmail: acce
tcp        1      0 192.168.1.50:55189          159.134.196.146:80          CLOSE_WAIT  2081/clock-applet  
tcp        0      0 :::445                      :::*                        LISTEN      30917/smbd          
tcp        0      0 :::5989                     :::*                        LISTEN      1477/cimserver      
tcp        0      0 :::56165                    :::*                        LISTEN      1164/rpc.statd      
tcp        0      0 :::139                      :::*                        LISTEN      30917/smbd          
tcp        0      0 :::111                      :::*                        LISTEN      1080/rpcbind        
tcp        0      0 :::22                       :::*                        LISTEN      1368/sshd          
tcp        0      0 ::1:631                     :::*                        LISTEN      1231/cupsd          
udp        0      0 0.0.0.0:831                 0.0.0.0:*                               1080/rpcbind        
udp        0      0 0.0.0.0:916                 0.0.0.0:*                               1164/rpc.statd      
udp        0      0 0.0.0.0:59444               0.0.0.0:*                               1139/avahi-daemon:  
udp        0      0 0.0.0.0:68                  0.0.0.0:*                               2149/dhclient      
udp        0      0 0.0.0.0:111                 0.0.0.0:*                               1080/rpcbind        
udp        0      0 0.0.0.0:631                 0.0.0.0:*                               1231/cupsd          
udp        0      0 192.168.1.50:123            0.0.0.0:*                               1390/ntpd          
udp        0      0 127.0.0.1:123               0.0.0.0:*                               1390/ntpd          
udp        0      0 0.0.0.0:123                 0.0.0.0:*                               1390/ntpd          
udp        0      0 0.0.0.0:58517               0.0.0.0:*                               1164/rpc.statd      
udp        0      0 0.0.0.0:18631               0.0.0.0:*                               2149/dhclient      
udp        0      0 0.0.0.0:5353                0.0.0.0:*                               1139/avahi-daemon:  
udp        0      0 :::831                      :::*                                    1080/rpcbind        
udp        0      0 :::50547                    :::*                                    1164/rpc.statd      
udp        0      0 :::111                      :::*                                    1080/rpcbind        
udp        0      0 fe80::6ef0:49ff:fe0:123     :::*                                    1390/ntpd          
udp        0      0 ::1:123                     :::*                                    1390/ntpd          
udp        0      0 :::123                      :::*                                    1390/ntpd          
udp        0      0 :::18115                    :::*                                    2149/dhclient      
[root@server3 ed]#
0
 
LVL 2

Expert Comment

by:PowerToaster
ID: 35215519
You mention setting disabled to no.

I assume you are using xinetd, if so have you checked to make sure it is running.
And if it is did you restart it after the configuration change?

service xinetd restart

Have you checked to see if selinux is blocking it?
0
 

Author Comment

by:fcek
ID: 35216594


Same problem

Latest ...............


root@server3 ed]# netstat -antpu | grep smbd
tcp        0      0 :::445                      :::*                        LISTEN      1656/smbd          
tcp        0      0 :::139                      :::*                        LISTEN      1656/smbd          
[root@server3 ed]#
[root@server3 ed]#
[root@server3 ed]# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination        

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination        

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination        
[root@server3 ed]#
[root@server3 ed]#
[root@server3 ed]# netstat -antpu
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name  
tcp        0      0 0.0.0.0:111                 0.0.0.0:*                   LISTEN      1191/rpcbind        
tcp        0      0 0.0.0.0:22                  0.0.0.0:*                   LISTEN      1561/sshd          
tcp        0      0 0.0.0.0:50902               0.0.0.0:*                   LISTEN      1277/rpc.statd      
tcp        0      0 127.0.0.1:631               0.0.0.0:*                   LISTEN      1345/cupsd          
tcp        0      0 127.0.0.1:25                0.0.0.0:*                   LISTEN      1602/sendmail: acce
tcp        0      0 192.168.1.50:44562          159.134.196.138:80          ESTABLISHED 2072/clock-applet  
tcp        0      0 192.168.1.50:41104          74.125.77.102:80            TIME_WAIT   -                  
tcp        0      0 192.168.1.50:57205          159.134.196.176:80          TIME_WAIT   -                  
tcp        0      0 192.168.1.50:47008          159.134.196.155:80          TIME_WAIT   -                  
tcp        0      0 192.168.1.50:60354          159.134.196.145:80          TIME_WAIT   -                  
tcp        0      0 :::445                      :::*                        LISTEN      1656/smbd          
tcp        0      0 :::5989                     :::*                        LISTEN      1684/cimserver      
tcp        0      0 :::901                      :::*                        LISTEN      1572/xinetd        
tcp        0      0 :::34826                    :::*                        LISTEN      1277/rpc.statd      
tcp        0      0 :::139                      :::*                        LISTEN      1656/smbd          
tcp        0      0 :::111                      :::*                        LISTEN      1191/rpcbind        
tcp        0      0 :::22                       :::*                        LISTEN      1561/sshd          
tcp        0      0 ::1:631                     :::*                        LISTEN      1345/cupsd          
udp        0      0 0.0.0.0:44887               0.0.0.0:*                               1277/rpc.statd      
udp        0      0 0.0.0.0:57259               0.0.0.0:*                               1250/avahi-daemon:  
udp        0      0 0.0.0.0:942                 0.0.0.0:*                               1191/rpcbind        
udp        0      0 0.0.0.0:64950               0.0.0.0:*                               1261/dhclient      
udp        0      0 0.0.0.0:68                  0.0.0.0:*                               1261/dhclient      
udp        0      0 0.0.0.0:605                 0.0.0.0:*                               1277/rpc.statd      
udp        0      0 0.0.0.0:111                 0.0.0.0:*                               1191/rpcbind        
udp        0      0 0.0.0.0:631                 0.0.0.0:*                               1345/cupsd          
udp        0      0 192.168.1.50:123            0.0.0.0:*                               1583/ntpd          
udp        0      0 127.0.0.1:123               0.0.0.0:*                               1583/ntpd          
udp        0      0 0.0.0.0:123                 0.0.0.0:*                               1583/ntpd          
udp        0      0 0.0.0.0:5353                0.0.0.0:*                               1250/avahi-daemon:  
udp        0      0 :::942                      :::*                                    1191/rpcbind        
udp        0      0 :::47561                    :::*                                    1277/rpc.statd      
udp        0      0 :::49669                    :::*                                    1261/dhclient      
udp        0      0 :::111                      :::*                                    1191/rpcbind        
udp        0      0 ::1:123                     :::*                                    1583/ntpd          
udp        0      0 fe80::6ef0:49ff:fe0:123     :::*                                    1583/ntpd          
udp        0      0 :::123                      :::*                                    1583/ntpd          
[root@server3 ed]# service xinetd restart
Stopping xinetd:                                           [  OK  ]
Starting xinetd:                                           [  OK  ]
[root@server3 ed]#
0
 
LVL 2

Accepted Solution

by:
PowerToaster earned 1000 total points
ID: 35216704
It shows that swat is listening now the line

tcp        0      0 :::901                      :::*                        LISTEN      1572/xinetd

is swat

Try http://127.0.0.1:901 instead of http://localhost:901
0
 

Author Closing Comment

by:fcek
ID: 35216973
Many many many thanks people.

This was going on a log long time.

I was beginning to despair.

I appreciate it so much.  Now back to this screaming baby :-)
0

Featured Post

Free Backup Tool for VMware and Hyper-V

Restore full virtual machine or individual guest files from 19 common file systems directly from the backup file. Schedule VM backups with PowerShell scripts. Set desired time, lean back and let the script to notify you via email upon completion.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Network Interface Card (NIC) bonding, also known as link aggregation, NIC teaming and trunking, is an important concept to understand and implement in any environment where high availability is of concern. Using this feature, a server administrator …
Google Drive is extremely cheap offsite storage, and it's even possible to get extra storage for free for two years.  You can use the free account 15GB, and if you have an Android device..when you install Google Drive for the first time it will give…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

719 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question