Solved

Server 2008 RAS when laptops vpn the network drives are not accessible unless you first UNC the ip of the server

Posted on 2011-03-22
3
375 Views
Last Modified: 2012-05-11
Hello everyone,

I have a server 2008 running RAS.  I am able to successfully connect from my laptop but when I try to access the network drive it says that it's unable to connect.

BUT

If I go to the run dialog and enter the ip address of the server via UNC (ie: \\192.168.1.2) the window opens showing all the shares AND then I can go into My Computer and access the network drive.  It wont even allow me to UNC with server name (ie: \\srv1).

If I decide to do nothing after I vpn (the UNC step) I noticed that the network drive will work if I wait 6-10 mins.  This is obviously not acceptable to our client.

I can also ping the ip but not the name.  I am thinking it's a dns issue not updating quickly or properly.

What can I do?!??!

Thanks

ceez
0
Comment
Question by:itbamiami
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 13

Accepted Solution

by:
AustinComputerLabs earned 250 total points
ID: 35195637
I would be interested to see if there is a really good solution.
I ahve a couple of clients that use VPN with RRAS and I create a batch file with a NET USE command (specifying the IP address) or make an entry in the hosts file on the client.

The client system is using the DNS servers from their NIC setup which do not include the server as an entry.
0
 

Author Comment

by:itbamiami
ID: 35198551
@austincomputerlabs: I guess I could give them a second script that disconnects their current network drive via \\servname and then reconnects them via \\servipaddrs.

Modifying the host file might be another solution, right now it's only 2 users allowed to use vpn but if it grows is will get out of hand to manually modify each time a new person is allowed to vpn.

I will wait and see if anyone else has gotten this problem and resolved it.

thanks for the reply
0
 
LVL 70

Assisted Solution

by:Qlemo
Qlemo earned 250 total points
ID: 35409036
Usually setting up a WINS server on the server site (and propagating the WINS server address to the VPN client) helps in that cases without further manipulation.
It is also likely that DNS suffixes are not propagated to the client, and/or the remote site's DNS server is not used in favour of the local one - which doesn't know anything about the remote names and IPs, because it is most likely the ISP's.
0

Featured Post

Why Off-Site Backups Are The Only Way To Go

You are probably backing up your data—but how and where? Ransomware is on the rise and there are variants that specifically target backups. Read on to discover why off-site is the way to go.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

OpenVPN is a great open source VPN server that is capable of providing quick and easy VPN access to your network on the cheap.  By default the software is configured to allow open access to your network.  But what if you want to restrict users to on…
Resolve DNS query failed errors for Exchange
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

623 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question