Solved

ASA config for a L2L

Posted on 2011-03-22
13
599 Views
Last Modified: 2012-08-13
Hello all,

I just configured a new asa using just the asdm.  I was wondering if anyone had a few minutes to look it over for any mistakes.

The L2L is between 10.91.150.0 and 10.92.39.0.  I have to take this new router to the locaton and was just trying to catch any errors before I got there.

Thanks for everyones help.

vne


ASA Version 8.2(1)
!
hostname xxx
enable password zkoJl1SfJD encrypted
passwd YhVDteqC3Zx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.91.150.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 66.76.XXX.XXX 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!            
interface Ethernet0/3
!            
interface Ethernet0/4
!            
interface Ethernet0/5
!            
interface Ethernet0/6
!            
interface Ethernet0/7
!            
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
access-list outside_cryptomap extended permit ip 10.91.150.0 255.255.255.0 host 10.92.39.0
access-list outside_access_in
access-list outside_access_in extended permit ip host 10.92.39.0 10.91.150.0 255.255.255.0
access-list inside_nat0_outbound
access-list inside_nat0_outbound extended permit ip 10.91.150.0 255.255.255.0 host 10.92.39.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.91.150.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map3 1 match address outside_cryptomap
crypto map outside_map3 1 set peer 206.255.XXX.XXX
crypto map outside_map3 1 set transform-set ESP-AES-256-SHA
crypto map outside_map3 interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash sha    
 group 2      
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!            
             
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn        
tunnel-group 206.255.XXX.XXX type ipsec-l2l
tunnel-group 206.255.XXX.XXX ipsec-attributes
 pre-shared-key *
!            
!            
prompt hostname context
Cryptochecksum:f34734f06d444cd835ca6c40b0
: end        
0
Comment
Question by:VNE
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 4
13 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 35197653
You need a default route if you have static IP on the outside interface
route outside 0.0.0.0 0.0.0.0 66.76.XXX.YYY  <- next hop, not your own IP

>host 10.92.39.0
Is this supposed to be a network, or a single host? We don't usually see .0 used as a host IP address..
0
 

Author Comment

by:VNE
ID: 35199329
Thanks Irmoore,

I added the correct route for the outside interface.  The 10.92.39.0 is a network on the other end of the L2L vpn.  The L2L is between the 10.91.150.0 network and the 10.92.39.0 network.  This isnt the scheme I would have used but this is the way it was already setup.  I'm just replacing some old 1700's with new ASA's.

ASA Version 8.2(1)
!
hostname xxx
enable password zkoJl1SfJD encrypted
passwd YhVDteqC3Zx encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.91.150.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 66.76.XXX.XXX 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!            
interface Ethernet0/3
!            
interface Ethernet0/4
!            
interface Ethernet0/5
!            
interface Ethernet0/6
!            
interface Ethernet0/7
!            
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
access-list outside_cryptomap extended permit ip 10.91.150.0 255.255.255.0 host 10.92.39.0
access-list outside_access_in
access-list outside_access_in extended permit ip host 10.92.39.0 10.91.150.0 255.255.255.0
access-list inside_nat0_outbound
access-list inside_nat0_outbound extended permit ip 10.91.150.0 255.255.255.0 host 10.92.39.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
route outside 0.0.0.0 0.0.0.0 66.76.XXX.XXX 1
http server enable
http 10.91.150.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map3 1 match address outside_cryptomap
crypto map outside_map3 1 set peer 206.255.XXX.XXX
crypto map outside_map3 1 set transform-set ESP-AES-256-SHA
crypto map outside_map3 interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash sha    
 group 2      
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!            
             
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn        
tunnel-group 206.255.XXX.XXX type ipsec-l2l
tunnel-group 206.255.XXX.XXX ipsec-attributes
 pre-shared-key *
!            
!            
prompt hostname context
Cryptochecksum:f34734f06d444cd835ca6c40b0
: end        
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 35200802
>The 10.92.39.0 is a network
OK, then if network and not a host,  both of these need to change:

>access-list outside_cryptomap extended permit ip 10.91.150.0 255.255.255.0 host 10.92.39.0
>access-list inside_nat0_outbound extended permit ip 10.91.150.0 255.255.255.0 host 10.92.39.0

Change to:
access-list outside_cryptomap extended permit ip 10.91.150.0 255.255.255.0 10.92.39.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 10.91.150.0 255.255.255.0 10.92.39.0  255.255.255.0
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:VNE
ID: 35204246
Thanks Irmoore,

I made the changes.

ASA Version 8.2(1)
!
hostname soler
enable workoJl1SfJ5hlJD encrypted
passwd zkoJl1SfJuu5hlJD encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.91.150.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 66.76.XXX.XXX 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!            
interface Ethernet0/3
!            
interface Ethernet0/4
!            
interface Ethernet0/5
!            
interface Ethernet0/6
!            
interface Ethernet0/7
!            
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
access-list outside_cryptomap extended permit ip 10.91.150.0 255.255.255.0 10.92.39.0 255.255.255.0
access-list outside_access_in remark L2L with Lonview
access-list outside_access_in extended permit ip host 10.92.39.0 10.91.150.0 255.255.255.0
access-list inside_nat0_outbound remark NAT exempt to Longview over vpn
access-list inside_nat0_outbound extended permit ip 10.91.150.0 255.255.255.0 10.92.39.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 66.76.XXX.XXX 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.91.150.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map3 1 set peer 206.255.XXX.XXX
crypto map outside_map3 1 set transform-set ESP-AES-256-SHA
crypto map outside_map3 interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash sha    
 group 2      
 lifetime 86400
telnet 10.91.150.0 255.255.255.0 inside
telnet timeout 15
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!            
             
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn        
tunnel-group 206.255.XXX.XXX type ipsec-l2l
tunnel-group 206.255.XXX.XXX ipsec-attributes
 pre-shared-key *
!            
!            
prompt hostname context
Cryptochecksum:7d3717cf24be68f8b071094aedae9a24
: end        


What about this line?
access-list outside_access_in extended permit ip host 10.92.39.0 10.91.150.0 255.255.255.0

Does the term "host" refer to just one device rather than an entire network?

0
 

Author Comment

by:VNE
ID: 35204367
Irmoore,

I made another change.  I needed to forward port 3389 to 10.91.150.5.


ASA Version 8.2(1)
!
hostname
enable password zkhlJD encrypted
passwd zkoJhlJD encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.91.150.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 66.76.XXX.XXX 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!            
interface Ethernet0/3
!            
interface Ethernet0/4
!            
interface Ethernet0/5
!            
interface Ethernet0/6
!            
interface Ethernet0/7
!            
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
access-list outside_cryptomap extended permit ip 10.91.150.0 255.255.255.0 10.92.39.0 255.255.255.0
access-list outside_access_in remark L2L with Lonview
access-list outside_access_in extended permit ip host 10.92.39.0 10.91.150.0 255.255.255.0
access-list outside_access_in extended permit tcp any interface outside eq 3389
access-list inside_nat0_outbound remark NAT exempt to Longview over vpn
access-list inside_nat0_outbound extended permit ip 10.91.150.0 255.255.255.0 10.92.39.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 10.91.150.5 3389 netmask 255.255.255.255
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 66.76.XXX.XXX 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.91.150.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map3 1 set peer 206.255.XXX.XXX
crypto map outside_map3 1 set transform-set ESP-AES-256-SHA
crypto map outside_map3 interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash sha    
 group 2      
 lifetime 86400
telnet 10.91.150.0 255.255.255.0 inside
telnet timeout 15
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!            
             
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn        
tunnel-group 206.255.XXX.XXX type ipsec-l2l
tunnel-group 206.255.XXX.XXX ipsec-attributes
 pre-shared-key *
!            
!            
prompt hostname context
Cryptochecksum:a91a92484f3a3e9f54
: end        
0
 

Author Comment

by:VNE
ID: 35204773
Hey Ilmoore,

I've got the other asa configured.  This asa is the one on the other end of the L2L vpn on the 10.92.39.0 network.  Do you mind looking at it also?  If need be I can open another question.  Thanks for your help.

ASA Version 8.2(1)
!
hostname asa-longview
enable password zkoJencrypted
passwd 2KFQnbNcrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.92.39.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 206.255.XXX.XXX 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!            
interface Ethernet0/3
!            
interface Ethernet0/4
!            
interface Ethernet0/5
!            
interface Ethernet0/6
!            
interface Ethernet0/7
!            
ftp mode passive
clock timezone CST -6
clock summer-time CDT recurring
access-list outside_1_cryptomap extended permit ip 10.92.39.0 255.255.255.0 10.91.150.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 10.92.39.0 255.255.255.0 10.91.150.0 255.255.255.0
access-list outside_access_in remark L2L with Tyler
access-list outside_access_in extended permit ip 10.91.150.0 255.255.255.0 10.92.39.0 255.255.255.0
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 206.255.XXX.XXX 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 10.92.39.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 set peer 66.76.XXX.XXX
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha    
 group 2      
 lifetime 86400
telnet 10.92.39.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
             
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn        
tunnel-group 66.76.XXX.XXX type ipsec-l2l
tunnel-group 66.76.XXX.XXX ipsec-attributes
 pre-shared-key *
!            
class-map inspection_default
 match default-inspection-traffic
!            
!            
policy-map type inspect dns preset_dns_map
 parameters  
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!            
service-policy global_policy global
prompt hostname context
Cryptochecksum:9a89e0f5046e2e168c4ed52bcb0e
: end        
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 35205982
Looks ok

To aid in troubleshooting and for your own sanity, I would add the following to both sides:

policy-map global_policy
 class inspection_default
  inspect icmp
  inspect icmp-error
0
 

Author Comment

by:VNE
ID: 35208264
On the first asa what do you think of this line:

access-list outside_access_in extended permit ip host 10.92.39.0 10.91.150.0 255.255.255.0

Should the word host be in there?
0
 

Author Comment

by:VNE
ID: 35208422
When I start the first asa I see this error when connected to the console.

.WARNING: crypto map has incomplete entries
*** Output from config line 86, "crypto map outside_map3 ..."

Right now the router is not connected to the network or internet.  Is this what is causing this error?
0
 

Author Comment

by:VNE
ID: 35208688
In your opinion Irmoore, should i just give up on using the asdm?  I have yet to get that thing to actually program the router correctly.  I always have to go back in with the cli and either fix things or add important things that the asdm left out.  Seems like it always takes me longer to program the router when I start out using the asdm.

Whats your opinion?  Here's an example.  Look at the first router config and you will see all of the below missing:

policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp

Where did this go?  I used the asdm on both routers exactly the same and on the second one all the above info is in there.  This is what I mean by having to go back in and fix the asdm's "errors".

Another example.  I had to go in with the cli on the first one and put in a route.  The router wont function without it but yet it doesnt ask you about it in the setup wizard.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 35211524
>access-list outside_access_in extended permit ip host 10.92.39.0 10.91.150.0 255.255.255.0
>Should the word host be in there?
Negative, you need to use subnet masks for network - network, unless it is a single host with the unlikely IP of 10.91.150.0

>In your opinion Irmoore, should i just give up on using the asdm?
Not completely. The startup wizard may be lacking, and is higly version dependent. I usually set mine up using CLI for the basic stuff. The VPN Wizard are worth their weight in gold. Getting a static nat's and other things working, I drop to CLI. Access-lists I stick with ASDM.
Once you get the thing going, ASDM is the best, IMHO, and I manage/maintain about 100 different ASA's for almost that many companies.


0
 

Author Closing Comment

by:VNE
ID: 35211663
Thanks for your help Irmoore.
0
 

Author Comment

by:VNE
ID: 35211671
I'm doing  a test installation of these two asa's tonight so I may be posting another question if I get stumped.  Thanks again for your help.

0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cisco 3650 switch licensing 6 80
Change name on 7940 Cisco UM 10 86
Error after upgrade of 3850s 15 95
Static Route on Cisco ISR 4431's 4 58
There are many useful and sometimes not well documented or forgotten IOS or ASA/PIX commands. See IPE article here , there was also one on PacketU and on Cisco Tips & Tricks. Below are my favorites. I give also a few most often used for Cisco IPS an…
I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question