Solved

Links doesnt works in Internet Explorer

Posted on 2011-03-23
11
296 Views
Last Modified: 2012-05-11
Hello,
One of our customers Internet Explorer behaves very odd. Links doesnt work. Nothing happens when clicked. I have tried to reset IE8, upgrade to IE9 but still the same.

The user uses Firefox now but they have some intra sites with links that Firefox cant handle, in IE it shows file://serv01/files/_Kvalitet/%20WEBBEN/Kopplade%20dokument/Affärsstrategi%20.htm

but in FF it shows
http://intra-companyname/\\%5C%5CC3%5Cfiles%5C_Kvalitet%5C%20WEBBEN%5CKopplade%20dokument%5CAff%C3%A4rsstrategi%20.htm

These are UNC paths and i have tried to let FF ignore the security of how it should translate them but it still doesnt works. So he cant use FF either. I want him to use IE so i need to fix IE for him. What should i do?

Btw, i have had the antivirus disabled so it is not that.
0
Comment
Question by:tommyrihu
  • 5
  • 4
  • 2
11 Comments
 
LVL 10

Expert Comment

by:Michael_MCDST
ID: 35199306
-
0
 
LVL 10

Expert Comment

by:Michael_MCDST
ID: 35199322
I have put something together for you here, hope it works. I have had some customers experiencing the same problem. Interestingly though it was usually associated with them having installed then remove Chrome. Make sure that you set IE as Default browser both before and after you use the script (if neccessary) but most importantly DO NOT run the script while any browsers are running - MOST IMPORTANT!
Open Notepad and copy the text below into it. Choose to Save As the notepad doc, change the file type selection to All files, name the file htmlfix.reg and save to desktop

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\.htm]
@="htmlfile"
[HKEY_CURRENT_USER\Software\Classes\.html]
@="htmlfile"
[HKEY_CURRENT_USER\Software\Classes\.shtml]
@="htmlfile"
[HKEY_CLASSES_ROOT\.xht]
@="htmlfile"
[HKEY_CLASSES_ROOT\.xhtml]
@="htmlfile"
[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
[HKEY_CLASSES_ROOT\https\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
Now right click the reg file and choose merge
0
 

Author Comment

by:tommyrihu
ID: 35207301
Hello and thank you very much for quick answer.

However, i tried to install and remove Chrome but that didnt work and the reg file said it couldnt be imported cause its not an register script. see the attachement, its in swedish though. Any ideas?
ie-error.png
0
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
LVL 80

Expert Comment

by:David Johnson, CD, MVP
ID: 35210320

curious about the companies file naming conventions ie. the trailing space after strategi and the leading space before WEBBEN you can copy and paste Michael's Text or download it here
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Classes\.htm]
@="htmlfile"
[HKEY_CURRENT_USER\Software\Classes\.html]
@="htmlfile"
[HKEY_CURRENT_USER\Software\Classes\.shtml]
@="htmlfile"
[HKEY_CLASSES_ROOT\.xht]
@="htmlfile"
[HKEY_CLASSES_ROOT\.xhtml]
@="htmlfile"
[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"
[HKEY_CLASSES_ROOT\https\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"

Open in new window

0
 
LVL 80

Expert Comment

by:David Johnson, CD, MVP
ID: 35210562
Fixed the link its now here
0
 
LVL 10

Expert Comment

by:Michael_MCDST
ID: 35213588
Ok, I take it that your system is Swedish? Despite the language difference the script should work regardless, have successfully used it on Danish systems as well. You could navigate the registry editor and make the changes shown in the script manually. Just time consuming though.
0
 

Author Comment

by:tommyrihu
ID: 35231128
Hello again

well the file did succefully merged but the problem remains. i checked manually regedit so that the changes were done and they were.

any other ideas?
0
 
LVL 10

Expert Comment

by:Michael_MCDST
ID: 35231402
Double check that IE is set as the default browser
0
 

Author Comment

by:tommyrihu
ID: 35241041
yes it is
0
 
LVL 10

Accepted Solution

by:
Michael_MCDST earned 125 total points
ID: 35241813
Strange that the script did not work. I am afraid that I have no other ideas. The script above has resolved 100% of all the cases regarding this issue that I have to date worked with.
0
 

Author Closing Comment

by:tommyrihu
ID: 35516888
we have given up.
0

Featured Post

Networking for the Cloud Era

Join Microsoft and Riverbed for a discussion and demonstration of enhancements to SteelConnect:
-One-click orchestration and cloud connectivity in Azure environments
-Tight integration of SD-WAN and WAN optimization capabilities
-Scalability and resiliency equal to a data center

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

It's here again; Microsoft is launching a new version of Internet Explorer: Internet Explorer 9, with noticeable changes on its interface, functions and new tools. As they say on its promotional video: "It's time to play, on a more beautiful web", f…
Several part series to implement Internet Explorer 11 Enterprise Mode
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
How to create a custom search shortcut to site-search Experts Exchange using Google in the Firefox browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch your Bookmark Menu: Press 'Ctrl +…

820 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question