Solved

Lync Server 2010 DNS problem

Posted on 2011-03-23
8
2,287 Views
Last Modified: 2012-05-11
Hi All,

I have installed Microsoft Lync Server 2010 - standard edition. I have managed to get everything working except getting the clients to connect automatically. I have adding the SRV record correctly and the Host A record, I have checked that I can ping the FQDN of the standard edition server and have also done an nslookup and all bring back the correct results. I think I know what the issue is but don't know how to correct it so here it is...

My FQDN of my server is servername.zone.mydomain.ac.uk however when using the automatic config in the desktop client I get the following error in my event viewer:

/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
Communicator was unable to locate the login server.  No DNS SRV records exist for domain mydomain.ac.uk, so Communicator was unable to login.
 
 Resolution:
 Please double-check the server name to make sure that it is typed correctly.  If it is correct, the network administrator will either need to use manual configuration to specify the login server's fully-qualified domain name (FQDN), or add DNS SRV records for the mydomain.ac.uk domain in order to allow automatic client configuration.  The DNS SRV records _sipinternaltls._tcp.mydomain.ac.uk, _sipinternal._tcp.mydomain.ac.uk and/or _sip._tls.mydomain.ac.uk may need to be configured if automatic configuration is desired.

/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

As you can see the two domain names do not match...for some reason the client is trying to connect to mydomain.ac.uk instead of zone.mydomain.ac.uk. I assume I must have configured something incorrectly during installation, however I have checked and re-created the topology with the correct FQDN of the server and the FQDN of the SIP domain. Does anyone have any suggestions I can try to resolve this?

Thanks

Natalie
0
Comment
Question by:brookesm
  • 4
  • 3
8 Comments
 
LVL 3

Expert Comment

by:madshjensen
Comment Utility
Try adding sip.yourdomain.com pointing to your FE server.
0
 
LVL 1

Author Comment

by:brookesm
Comment Utility
What kind of DNS record? Host A?
0
 
LVL 3

Expert Comment

by:madshjensen
Comment Utility
Try it out as a Host A.
0
 
LVL 1

Author Comment

by:brookesm
Comment Utility
No that didn't work. Any other suggestions?
0
Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

 
LVL 3

Expert Comment

by:madshjensen
Comment Utility
Did you log out/in of Windows afterwards? Try adding it as a cname then, but I'm not sure if it'll work. You're certain you've added the SRV records correctly, as described in your question?
0
 
LVL 3

Expert Comment

by:madshjensen
Comment Utility
Have a look at the requirements here:
http://technet.microsoft.com/en-us/library/gg398082.aspx
0
 
LVL 1

Author Comment

by:brookesm
Comment Utility
Hi,

Yes I have added the SRV and Host A records for my domain, however the error returned is not for the FQDN of hsfc.mydomain.ac.uk it is for mydomain.ac.uk so for some reason it is not using the FQDN and I don't know why!

Thanks
0
 
LVL 12

Accepted Solution

by:
Jeff_Schertz earned 500 total points
Comment Utility
What is the SIP domain that the client is signing-in with?

For example, if you are trying to sign in with "user1@mydomain.ac.uk" then Lync will automatically search for the SRV (and A fall-back) records in the "mydomain.ac.uk" domain.  you cannot use SRV and A records in the hsfc.mydomain.ac.uk domain in which the server's FQDN is (e.g. lyncfe.hsfc.mydomain.ac.uk).

You need to create the SRV record (_sipinternaltls._tcp.mydomain.ac.uk ) and associated A record (sip.mydomain.ac.uk) and ten make sure that the certificate on the Lync server has that A records included in it's SAN (sip.mydomain.ac.uk).

The configuration above is the only supported solution, you cannot point and SRV record in one domain to an A record in a different domain as the Lync client will fail to login.  So do not point _sipinternaltls._tcp.mydomain.ac.uk to the server's FQDN (e.g. lyncfe.hsfc.mydomain.ac.uk) since those are not in the same DNS forward lookup zone.

0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This tutorial will walk an individual through the steps necessary to enable the VMware\Hyper-V licensed feature of Backup Exec 2012. In addition, how to add a VMware server and configure a backup job. The first step is to acquire the necessary licen…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now