• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1477
  • Last Modified:

Lotus Notes 7.0 mailto issue

Hi There,

I have a strange one which may not have a resolve .. but thought I would ask.

I realise there is alot of functions within Lotus Notes which are not supported in a terminal server environment but maybe someone knows something.

I have setup my mailto command as follows
C:\notes\nlnotes.exe -defini %1

If I load a published desktop *AND DO NOT OPEN LOTUS NOTES* .. I can go to our company intranet through IE .. and click on a mailto link and it will launch Lotus Notes .. prompt the user for password and seccessfully start a new memo with the supplied contact from the mailto command from the Intranet.

However....

When i click an mailto link while Lotus Notes is open, a New Memo is not created. Am i missing a parameter on my mailto command for it to work? We are using PS 4.5, where the problem persists. On my local client i dont have any problem with the same parameter. Might it be Lotus Notes isnt a good mailclient for Citrix?
0
PonLogistiek
Asked:
PonLogistiek
2 Solutions
 
SysExpertCommented:
Not sure. But in general, Notes has to be set as the Default Mail client for this to work, so I would check the settings in IE for the mail client in each case to compare.

I hope this helps !
0
 
jvr006Commented:
This is for Outlook, but may help..
http://support.citrix.com/article/CTX120688
0
 
larsberntropCommented:
Search Redboojks and Domino wiki for Citrix and terminal server info.  A lot DOES work, if correctly setup.  I think the -defini prametrer is throwing a spanner in your process, and you should explicitly define the note.ini to be used for the user by specifying it with the = parameter.

But all this has been documented in docs available at aforementioned locations.
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
PonLogistiekAuthor Commented:
LN is set as the default mail client in IE as on Windows. Strange of all is that, when iim using a local client, same config (except the OS version) above mentioned problem dont appear. Im using the same parameters (-defini).
0
 
larsberntropCommented:
I don't know if defini is the right parameter to use.
0
 
PonLogistiekAuthor Commented:
I know -defini is a mandatory setting from LN. Found another option @ the IBM site, but this doesnt seem to work for me:

Question
After you install Lotus Notes 8.x Standard Configuration, you add the -sa switch to the launch icon so it launches the Basic Configuration instead. How can you do the same for mailto: links?
 
Answer

1. Go to Control Panel -> Folder Options -> Files Tab -> URL: MailToProtocol.

2. Select the Open action and click Edit. The command line should look like this:

c:\installPath\Notes\notes.exe -defini %1

3. Add the -sa parameter like this:

c:\installPath\Notes\notes.exe -sa -defini %1


Note: Please do not remove the "-defini" parameter because it us used to prevent malicious URLs to launch notes via Windows registry by having an "=\\evilhost\notes.ini" on the command line.
0
 
larsberntropCommented:
Evn when you define your own with an =- parameter?
0
 
PonLogistiekAuthor Commented:
Problem seems to be at our 3rd party software (RES Workspace Manager). Items will be closed with no points.
0
 
PonLogistiekAuthor Commented:
none
0

Featured Post

Configuration Guide and Best Practices

Read the guide to learn how to orchestrate Data ONTAP, create application-consistent backups and enable fast recovery from NetApp storage snapshots. Version 9.5 also contains performance and scalability enhancements to meet the needs of the largest enterprise environments.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now