Solved

PUSH FEATURE ON MOBILE PHONES

Posted on 2011-03-23
37
258 Views
Last Modified: 2012-06-21
I am having trouble enabling the PUSH on the mobile phones using exchange active sync. I have check all over google, seems a lot of peope face the same issue. Any ideas?
0
Comment
Question by:Bigmerv307
  • 19
  • 17
37 Comments
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35198159
What version of Exchange do you have?
0
 

Author Comment

by:Bigmerv307
ID: 35198291
Exchange server 2003
0
 
LVL 76

Accepted Solution

by:
Alan Hardisty earned 500 total points
ID: 35198307
Okay - in that case, please have a read of my article and if you get stuck anywhere - please ask.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:Bigmerv307
ID: 35198311
it worked fine before and then it stop. At the office i have IPONES, ANDROIDS, BLACKBERRYS
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 35198343
My article will help you determine why.  The test site will give some clues and the IIS settings should be checked in case something changed.

Also - your SSL certificate might have expired or port 443 might be blocked.
0
 

Author Comment

by:Bigmerv307
ID: 35198377
FYI, I have SBS 2003 with Exchange server included. port 443 is open. The real issue is, the mail comes in, but i have to maually refresh or just keep the mail open. then all the mail pops in. If i set the phone to PUSH or AS MAIL ARRIVE it switches right back to manual.
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 35198385
Look at the Inconsistent Sync section of my article - you have problems with Anti-Virus interference and need to add a registry key:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_1798-Exchange-2003-Activesync-Connection-Problems-FAQ.html
0
 

Author Comment

by:Bigmerv307
ID: 35198553
Thank so much for all your help. i will update you. I use trend micro worry free business security. Can i just add this line to my registry without causing any issues? Would i need to reboot the server?
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 35198573
Some Anti-Virus software has a setting and changing the registry key / adding it will mean the software overwrites it - others are fine by just adding it.

As far as I am aware - the server will not need to be rebooted, but if it doesn't make things work fairly quickly - then a reboot should mean the key gets referenced and should take effect.
0
 

Author Comment

by:Bigmerv307
ID: 35200338
I really appreciate all the information you sent. But it turned out that i already had this line in my registry. I tried calling the trend micro support, still no luck. i rebooted the server, still no PUSH. Last week all was fine, Friday , PUSH stopped working.
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 35200396
Please visit the test site mentioned in my article and see what that yields.  Run the Exchange Activesync test and specify manual server settings.

Please post the results.

Thanks

Alan
0
 

Author Comment

by:Bigmerv307
ID: 35200446
should i run this from my desktop or the server?
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 35200468
It makes no difference - it is a web-based test and can be run on any computer internally or externally - the results will be the same no matter where it is run.
0
 

Author Comment

by:Bigmerv307
ID: 35200503
ExRCA is testing Exchange ActiveSync.  
  The Exchange ActiveSync test failed.
   Test Steps
   Attempting to resolve the host name mail.domain.com in DNS.
  The host name resolved successfully.
   Additional Details
  IP addresses returned: 173.220.xxx.xxx
 
 Testing TCP port 443 on host mail.domain.com to ensure it's listening and open.
  The port was opened successfully.
 Testing the SSL certificate to make sure it's valid.
  The SSL certificate failed one or more certificate validation checks.
   Test Steps
   Validating the certificate name.
  Certificate name validation failed.
   Tell me more about this issue and how to resolve it
   Additional Details
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 35200517
Okay - your certificate is named with an IP Address, so you can't use the test site to test with.

Are you entering the IP Address as the servername for your Activesync devices?
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 35200524
Your certificate was created on the 5th March 2010 - is that when the troubles began?
0
 

Author Comment

by:Bigmerv307
ID: 35200544
i did not create it , the issue was off and on, but Friday the 18th it really stopped working
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35200563
Okay - but what is the name you are using on your mobiles for the servername?
0
 

Author Comment

by:Bigmerv307
ID: 35200593
mail.domain.com on the iphones and the external ip on the andriod.
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 35200611
Okay - for Activesync to work - the name you use as the servername needs to match the name on the certificate (although some phones are not quite as fussy!).

Is your Exchange Server part of an SBS server?
0
 

Author Comment

by:Bigmerv307
ID: 35200626
yes it is part of the sbs server.
0
 
LVL 76

Assisted Solution

by:Alan Hardisty
Alan Hardisty earned 500 total points
ID: 35200666
Great - in that case - please re-run the Connect To The Internet Wizard (Start> Server Management> To-Do-List) and change nothing apart from when you get to the Certificate part where you should create a new Certificate called mail.domain.com and then complete the wizard.

Once you have done that - then you can use the test site, run the same test, specify manual server settings, tick the Ignore Trust for SSL check box and get past the certificate error, at which point, if you do get an error, my article will be able (should be able) to assist you in resolving it.
0
 

Author Comment

by:Bigmerv307
ID: 35200860
i get this error when i try to run Internet wizard.

The wizard cannot set the DHCP scope options. Ensure that the DHCP server service is running and that a scope is defined. Alternatively, disable the DHCP service manually, and then configure your client computer IP address properties. For more information about manually configuring client computers, see Help and Support.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35200873
Is your server dishing out IP Addresses or is your Router?  Ideally it should be your server?
0
 

Author Comment

by:Bigmerv307
ID: 35200925
I use static here on all the desktops, and the server i think gave dhcp.  I'm, so confused, no idea what's going on here. lol
0
 

Author Comment

by:Bigmerv307
ID: 35201124
ok, so i disabled the dhcp on the router.
0
 

Author Comment

by:Bigmerv307
ID: 35201223
i enable dhcp on the server and ran the internet wizard.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35202011
Sorry - headed home.

Did you create a new certificate?

Have you run the test on the test site again?

What are results?
0
 

Author Comment

by:Bigmerv307
ID: 35207199
all is fine now. You are the best. I now pronounce you KING OF EXPERTS-EXCHANGE. THANK YOU SO MUCH for all the info .

Today i will purchase a third party cert. with the correct domain.

Thanks again
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35207302
: ) - You are very kind.

If you want a cheap certificate - have a look at my profile ; )
0
 

Author Comment

by:Bigmerv307
ID: 35207349
ok, thx
0
 

Author Comment

by:Bigmerv307
ID: 35207388
on which page, i just went through the article and did not find it.
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35207428
Just under the Member Profile part:

http://www.experts-exchange.com/M_4926565.html
0
 

Author Comment

by:Bigmerv307
ID: 35207633
i ordered the cert. thank you
0
 
LVL 76

Expert Comment

by:Alan Hardisty
ID: 35207728
Thank you.
0
 

Author Comment

by:Bigmerv307
ID: 35214256
ExRCA is testing Exchange ActiveSync.  
  Exchange ActiveSync was tested successfully.
   Test Steps
   Attempting to resolve the host name mail.domain.com in DNS.
  The host name resolved successfully.
   Additional Details
  IP addresses returned: 173.220.xxx.xxx
 
 Testing TCP port 443 on host mail.domain.com to ensure it's listening and open.
  The port was opened successfully.
 Testing the SSL certificate to make sure it's valid.
  The certificate passed all validation requirements.
   Test Steps
   Validating the certificate name.
  The certificate name was validated successfully.
   Additional Details
  Host name mail.domain.com was found in the Certificate Subject Common name.
 
 Validating certificate trust for Windows Mobile devices.
  The test passed with some warnings encountered. Please expand the additional details.
   Additional Details
  The certificate is only trusted on Windows Mobile 6.0 and later versions. Devices running Windows Mobile 5.0 and 5.0 with the Messaging and Security Feature Pack won't be able to sync. Root = OU=Starfield Class 2 Certification Authority, O="Starfield Technologies, Inc.", C=US.
 
 Testing the certificate date to confirm the certificate is valid.
  Date validation passed. The certificate hasn't expired.
   Additional Details
  The certificate is valid. NotBefore = 3/24/2011 6:31:43 PM, NotAfter = 3/24/2015 6:31:43 PM
 
 
 
 Checking the IIS configuration for client certificate authentication.
  Client certificate authentication wasn't detected.
   Additional Details
  Accept/Require Client Certificates isn't configured.
 
 Testing HTTP Authentication Methods for URL https://mail.domain.com/Microsoft-Server-Activesync/.
  The HTTP authentication methods are correct.
   Additional Details
  ExRCA found all expected authentication methods and no disallowed methods. Methods found: Basic
 
 An ActiveSync session is being attempted with the server.
  Testing of an Exchange ActiveSync session completed successfully.
   Test Steps
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scam emails are a huge burden for many businesses. Spotting one is not always easy. Follow our tips to identify if an email you receive is a scam.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

740 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question