Windows cannot find the hostname "" using DNS

Posted on 2011-03-23
Last Modified: 2012-05-11

When I try to access the website - I receive the error:   Windows cannot find the hostname "" using DNS

When I try to access that same website from my work PC or even my phone - it comes up fine.  My home PC and laptop (which cannot reach the site either) are both Vista machines.  My work PC is Win 7 and my phone(s) are BB and Android.

I Googled this and tried some suggestions such as releasing/renewing & flushing the DNS but none of that worked.  I also tried unplugging the modem and router and replugging them in.  

I do not have this issue with any other websites ...

Question by:nancyk2000
  • 3
  • 3
  • 2
  • +3

Expert Comment

ID: 35198292
this might not be your problem.
It sounds like your DNS (which your ISP usually provides) is a bit screwey.
As a test, you can change your router to give out a different DNS to the clients.
In the router, put in a "fixed" dns of - this is a public google DNS .
then do a release/renew on your notebook to get the new settings...
see if that helps?

Author Comment

ID: 35198328

I dont know how/where to do this on a router - do I just enter the IP address of the router and go from there or ?

Accepted Solution

zazagor earned 400 total points
ID: 35198329
This is definitivley a DNS lookup problem. Here are some suggestions:
1) at command prompt:  ipconfig /flushdns
2) inactivate/activate network adapter
3) change manually to a different DNS server
4) edit the hosts file, add:

How our DevOps Teams Maximize Uptime

Our Dev teams are like yours. They’re continually cranking out code for new features/bugs fixes, testing, deploying, responding to production monitoring events and more. It’s complex. So, we thought you’d like to see what’s working for us. Read the use case whitepaper.


Expert Comment

ID: 35198331
Are you getting any error in the Application log on the Vista machine, example as below.

Event Type: Error
Event Source: AutoEnrollment
Event Category: None
Event ID: 13
Date: Date
Time: Time
User: N/A
Computer: Computer
Automatic certificate enrollment for Local system failed to enroll the CertType certificate from CA-name

Expert Comment

ID: 35198368
what other you can do is that install the latest service pack

or else the other workaround is that, add an entry for the remote host to the Hosts file on the client computer. The Hosts file is located in the following folder:

Expert Comment

ID: 35198383
although adding the entry manually will get to that address, there is still an underlying problem with the network setup.
Nancy2000, what type of router do you have?
i *may* be able to help you reconfigure it...

Author Comment

ID: 35198419

I have a Linksys router ...

Expert Comment

ID: 35198565
if you open your browser, and enter you will get to the login of the router.
leave the username blank and enter 'admin' in the password field. This is the default. If you have changed it, then login with whatever you changed it to.

On the main page, you will see a section called "dhcp server settings". DHCP server should be set to enabled. a few lines down you will see "static DNS 1:". enter (an 8 in each of the 4 boxes).
click the save settings button on the bottom of the page.
you will get a notice that the settings were changed/saved successfully.

on your computer, click the strat button and in the run box type 'cmd" then the enter key. This will bring up a black box/window.

Type 'ipconfig /release' then press enter
type 'ipconfig /renew' then press enter

see if that fixes the problem

Assisted Solution

Press2Esc earned 100 total points
ID: 35198736
Adding the domain name & ip to the hosts table (above) should work, but it more fixing the symptom than solving the problem...  In any case, you definitely have a DNS issue...

Q1. At the problem system, in the command line window, when you ping what is the addr shown?
 (e.g., ) ping >> Pinging [] with 32 bytes of data:

2. in the same command line window, do the following
netsh interface ip delete arpcache
arp -a (should show arp cache is cleared)

3. now ping at your should get  
- If not, open a browser and enter into the address bar - it should take you to Barclaycardus.

4. I am not sure of your OS, but you are still having a prob, change to diff dns server (enter the following 2 commands)

> ipconfig/all (and note both your dns servers for the CORRECT adapter (Ethernet, wireless, etc);
 Default Gateway . . . . . . . . . :
 DNS Servers . . . . . . . . . . . :  (this is primary)
                                       (this is secondary)
 NetBIOS over Tcpip. . . . . . . . : Enabled

> netsh interface ip set dns "Local Area Connection" static

NOTE: Delete your browser cache & try again... If this works, your problem is/was your primary (vs secondary) dns server & with a new DNS set you are good to go.  If you have other prob system, enter the same  "netsh" command on the other adapter/systems.

> netsh interface ip set dns "Local Area Connection" static

Per my above instructions, pls post any problems or inconsistancies...

Good luck!


Author Comment

ID: 35198749

I will try this all at home tonight and report back & accept solutions (hopefully!) tomorrow morning - thank you!

LVL 46

Expert Comment

by:Craig Beck
ID: 35198844
Try using NSLOOKUP at the command prompt.

Click on the Start button and enter CMD into the search field.
Click on the CMD icon when it appears in the search results.

A black window will appear.

At the prompt type:

You will be prompted with something like the following:
Default Server:  UnKnown


Type the following at the > prompt:

If you get the following output DNS is ok:

Non-authoritative answer:

If you don't get that response type the following at the > prompt:


Then type:

If you get a response similar to the below you need to change your DNS servers:

Non-authoritative answer:


Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

I've written instructions for one router type, but this principle may be useful for others of the same brand and even other brands of router. Problem: I had an issue especially with mobile devices that refused to use DNS information supplied via…
When you try to extract and to view the contents of a Microsoft Update Standalone Package (MSU) for Windows Vista, you cannot extract the files from the MSU. Here we are going to explain how to extract those hotfix details without using any third pa…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Finds all prime numbers in a range requested and places them in a public primes() array. I've demostrated a template size of 30 (2 * 3 * 5) but larger templates can be built such 210  (2 * 3 * 5 * 7) or 2310  (2 * 3 * 5 * 7 * 11). The larger templa…

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question