perl Error

What ever program I run I am getting the following error, I have perl 5.8.8 installed...

Can't locate warnings/register.pm in @INC (@INC contains: /usr/opt/perl5/lib64/5.8.8/aix-thread-multi-64all /usr/opt/perl5/lib64/5.8.8 /usr/opt/perl5/lib64/site_perl/5.8.8/aix-thread-multi-64all /usr/opt/perl5/lib64/site_perl/5.8.8 /usr/opt/perl5/lib64/site_perl .) at /usr/opt/perl5/lib64/5.8.8/vars.pm line 7.
BEGIN failed--compilation aborted at /usr/opt/perl5/lib64/5.8.8/vars.pm line 7.
Compilation failed in require at /usr/opt/perl5/lib64/5.8.8/File/Spec.pm line 4.
BEGIN failed--compilation aborted at /usr/opt/perl5/lib64/5.8.8/File/Spec.pm line 4.
Compilation failed in require at /usr/opt/perl5/lib64/5.8.8/aix-thread-multi-64all/IO/File.pm line 134.
BEGIN failed--compilation aborted at /usr/opt/perl5/lib64/5.8.8/aix-thread-multi-64all/IO/File.pm line 134.
Compilation failed in require at /usr/local/bin/pdu line 4.
BEGIN failed--compilation aborted at /usr/local/bin/pdu line 4.
mnis2008Asked:
Who is Participating?
 
woolmilkporcCommented:
Seems that you'll have to reinstall all the packages which didn't come with the original AIX Perl (the ones you installed by yourself into Perl 5.8.4, that is) to have them available in the 5.8.8 hierarchy.

wmp
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.