Solved

linux

Posted on 2011-03-23
7
280 Views
Last Modified: 2013-12-16
Dear Experts:

Iam having centos when login to gui home dir were avalaible , suddenly disappered the home and profile is some waht new. to fix texecuted rm -rf .* in the /root after that when done startx x still the same no home dir appears but then take a terminal from the gui it starts with like below
bash-3.2# pwd
/root
bash-3.2#

Please help me to fix this.
Thanks in advance.

0
Comment
Question by:D_wathi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 

Author Comment

by:D_wathi
ID: 35199213
After coping the files from /etc/skel the consle from gui got changed to normal.[root@srv1 ~]#

but still the home dir and a default profile is missing it only loads a blank and task bar above and below please suggest me to bring it back to default or normal profile. Thanks in advance.
0
 
LVL 2

Expert Comment

by:maxalarie
ID: 35199497
First : Nerver use  the command rm -rf when logged as root.  NEVER!
 
The home dir of root is /root and the home dir of users is /home.

Can you confirm /home exist?


0
 
LVL 31

Accepted Solution

by:
farzanj earned 500 total points
ID: 35199584
Which account are you talking about?

First you need to login as root.

If you don't have your basic configurations, you can get some of it at least back by issuing the following command

cp -a /etc/skel/.* ~<userID>/

This should give at least part of the configuration you lost.
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 

Author Comment

by:D_wathi
ID: 35200508
Thanks for for the reply. problem is when login as root and startx for gui iam not getting the default gui profile which will have home dir of root on the desktop also if tum drive is inserted automcatic display all this is not there now. cany anybody please give me the steps to correct this. Thanks in advance.
0
 
LVL 2

Expert Comment

by:maxalarie
ID: 35200556
Try entering  this command as root:   init 5
0
 
LVL 12

Expert Comment

by:mccracky
ID: 35202090
You need to look at your window manager configuration.  What window manager are you using?
0
 

Author Comment

by:D_wathi
ID: 35206116
Thanks for the reply , using gnome windows manager. Please suggest
0

Featured Post

Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Linux users are sometimes dumbfounded by the severe lack of documentation on a topic. Sometimes, the documentation is copious, but other times, you end up with some obscure "it varies depending on your distribution" over and over when searching for …
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question