When trying to delete a file, it says "could not find this item".

I am running windows 7.  There's a file in a folder that has no file extension.  I selected to show file extensions and to view hidden and system files. This PC is an FTP server, so there's multiple people who have access to write/read on this PC.  I have included a copy of error message in the attached picture.

I have already restarted the computer and even performed a chdsk /r, and that didn't fix anything. I still can't delete the file.  I've even taken ownership of the folder that the file is in, and that didn't work.  I'm logged in as the local administrator, so I have full access.
I even tried delete the file in the cmd line as well, still didn't delete.

I can't figure this out, I've never ran across this before, so if someone can point me in the right direction, that would be great.


 
fileError.jpg
afactsNetwork EngineerAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
beaktConnect With a Mentor Commented:
OK, I assume you're abbreviating the output error message you're reporting here, or that this is a different file you're talking about now.  You used quotation marks around the file name, right?  Best way to ensure you're doing this right at the command prompt is:

del b.   [the pressTab]

Then it should fill in the full name of the file, with quotation marks.

Sorry for being so rigorous, I just want to make sure we're not spinning our wheels in case it's a little thing.

Also, have you tried Safe Mode?  I'm not sure how a program locking the file would generate "file not found", but it's worth a try.  If that were to work, we could then start working on how to isolate what program was causing the problem and how.

Jeff
0
 
beaktCommented:
Let's use the "try the easiest things first" method.

Have you tried from the command prompt?  If so, what is the error message?

Have you tried renaming the file first?

Jeff
0
 
bitlaConnect With a Mentor Commented:
It happens to the some of the ftp client software and for custom made ftp softwares, even after you delete the file it shows its there but it is actually got deleted, and when you try to delete again you will receive the error "could not find the file" or could not find this item.

I suggest you to use other ftp programs or use windows explorer and you will notice that the file is actually deleted and does not exists.
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
afactsNetwork EngineerAuthor Commented:
Yes, I tried using the cmd prompt, and it says
"could not fine C:\ftp\afcoe\afcoe_india_files\dan2\dan\b."

So I was able to rename the folders where the file is located, but it does not let me rename the file it says, it gives me the exact same error message.
0
 
afactsNetwork EngineerAuthor Commented:
I'm actually using windows explorer on the computer itself, I'm not logged in via the FTP software, I'm actually using windows explorer and the CMD prompt.
0
 
jcimarronConnect With a Mentor Commented:
afacts--  Have you tried deleting the folder?  
If no help, try using Move on Boot.
http://www.emco.is/products/move-on-boot/features.php
or Unlocker
http://www.majorgeeks.com/download4660.html
0
 
bitlaCommented:
Restart the server and check again
0
 
afactsNetwork EngineerAuthor Commented:
I tried it in the CMD, like you said, I typed del b. and pressed tab, and it just put the entire name there, but it still says "could not fine C:\.......)

I will try safe mode, I will restart the server now and get back to you.

I tried deleting the folder, but it won't let me know, it prompts me with the same error message, as it can't find the file.

I'll try the move/boot here in a few minutes after I restart it, as that's quicker.

I've already restarted the PC.




afacts-436042.flv
0
 
afactsNetwork EngineerAuthor Commented:
Ok, I went into safe mode and it still did not work.  Same error message.
Then I rebooted into safe mode with CMD support.  I tried to rename and delete it, but it still did not work.
So I got the idea, in the CMD prompt, I did a a del *.* in that folder, and first I copied everything in there to the desktop, and then tried the command, and guess what, it worked, by deleting everything in that directory, it deleted the corrupt file as well.

So thank you guys for your assistance!!!!!!!!!!!!!!!!!!!!!
0
 
afactsNetwork EngineerAuthor Commented:
thanks for everyone's input,  I was pointed into the right direction.
0
 
beaktCommented:
You're welcome, afacts.  You nuked the folder!  I'm glad that worked.  If it happens again, please post again and let us know.  I'm interested to nail down how the directory entry got corrupted.
0
 
jcimarronCommented:
afacts--Glad to hear all is well.
0
All Courses

From novice to tech pro — start learning today.