Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 805
  • Last Modified:

Emails with .gov extension are stuck in queue

For some odd reason Exchange 2003 won't send out emails ending with a .gov extension, they just stay stuck in the queue. Everything else goes out just fine. This started a few weeks ago. I haven't made any changes, but it does the regular windows updates.

I use Sendlabs SMTP to send out email because it is lot easier than dealing with AT&T's constantly shifting rules with spam, it is running on Windows Server 2003 behind a Sonicwall TZ190 firewall.

I have cleared cached DNS stuff on DNS server and restarted the machine, still .gov emails are still getting stuck then eventually sending back an error saying "No route was found for the recipient server."

How do I fix this?
0
Bob Stone
Asked:
Bob Stone
  • 9
  • 8
  • 2
  • +1
1 Solution
 
Justin OwensITIL Problem ManagerCommented:
If you do an NSLOOKUP of the .gov domain to which you are trying to send from your Exchange server(s), does it correctly resolve?

DrUltima
0
 
I QasmiCommented:
Check the mail id through which the messages are being sent to various recepients.
Does the sender exist in the AD Database or not if not then check for the validity of the sender
through testexchangeconnectivity.com Situations comes into picture when there might be spam attack causing emails to get stuck in the queue.
0
 
Bob StoneIT GuruAuthor Commented:
I got a DNS timeout on the nslookup.

The mail IDs are valid, most of the current ones are from me as a test.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Justin OwensITIL Problem ManagerCommented:
Can you paste the results in for me?
0
 
Bob StoneIT GuruAuthor Commented:
Upon digging through DNS settings I noticed that the resolver was set to an old OpenDNS account that expired a while back, after changing it to the new DynDNS one I have now it was able to resolve ... sorta, I get some odd results, it adds my domain name to the end of it for some odd reason.

C:\Documents and Settings\exchange>nslookup ssa.gov
Server:  server.adname.extdomain.org
Address:  192.168.1.156

Non-authoritative answer:
Name:    ssa.gov.extdomain.org
Address:  216.146.35.99

Open in new window


Why would it do that?
0
 
Alan HardistyCo-OwnerCommented:
Bob,

Please have a read of my article (which hopefully makes sense) and shout if you get stuck anywhere:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/A_2427-Problems-sending-mail-to-one-or-more-external-domains.html

You need to check you are RFC compliant and that means Reverse DNS, FQDN on your SMTP Virtual Server doesn't end .local - which they often do on Exchange 2003 unless changed manually, you are not blacklisted and the world loves you : )

Alan
0
 
Bob StoneIT GuruAuthor Commented:
OK will do, but it is supposed to be sending all the mail through to DynDNS' SendLab SMTP service, why wouldn't they just go out like everything else?
0
 
Alan HardistyCo-OwnerCommented:
Are you using an SMTP Connector or just the SmartHost option on the SMTP Virtual Server?

Could be a screwy SMTP Connector causing you headaches.
0
 
Bob StoneIT GuruAuthor Commented:
An SMTP connector configured with authentication.
0
 
Alan HardistyCo-OwnerCommented:
Might be a good idea to download Metabase Explorer and see what's cooking in your Metabase!

http://support.microsoft.com/kb/840671

You might have an entry in the Metabase causing the problem.
0
 
Alan HardistyCo-OwnerCommented:
Have you tried deleting and creating a new SMTP Connector?
0
 
Bob StoneIT GuruAuthor Commented:
I will try killing the SMTP connector and redoing it. I dunno why I didn't think of that. But first it is break time, I'll let you know in about 15 or so.
0
 
Alan HardistyCo-OwnerCommented:
:) - Enjoy.
0
 
Bob StoneIT GuruAuthor Commented:
Deleted SMTP connector, added new SMTP connector, and restarted SMTP service. No change :(

It still strikes me as odd that the NSlookup would be fine but it gets stuck and there is no cached lookup in DNS entries, does it need a manual DNS entry or something?
0
 
Alan HardistyCo-OwnerCommented:
It shouldn't need anything - if the Address Space is * - everything should leave the building.

Did you download Metabase Explorer?
0
 
Bob StoneIT GuruAuthor Commented:
Just did, what am I supposed to be looking for?
0
 
Alan HardistyCo-OwnerCommented:
Look under:

Server> LM> SmtpSvc> 1> Domain

Anything .gov listed?
0
 
Alan HardistyCo-OwnerCommented:
Worst case - try creating a new SMTP Connector - scope it just for the .gov domain and send via DNS.  Stop and restart the SMTP Service and see if the messages leave the building.
0
 
Bob StoneIT GuruAuthor Commented:
Worked like charm. Thanks a ton m8 :)
0
 
Bob StoneIT GuruAuthor Commented:
Worked like charm. Thanks a ton m8 :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 9
  • 8
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now