Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 303
  • Last Modified:

linux, entrprise linux 5, nfs

Hi,
I have a server that runs Linux Entrprise 5 with nfs shares mounted on a windows server.

For some reason, every time i write new files to the directory they are created with the following credentials: 500 root

is there any way to change that to the id and group that i need?
0
vburshteyn
Asked:
vburshteyn
1 Solution
 
wesly_chenCommented:
The setting is on Windows side.
It depends on what NFS client you use on Windows side.

If you use Windows service for Unix , you check this URL
http://technet.microsoft.com/en-us/library/bb463218.aspx

Basically map your Linux UID/GID to your Windows login account
0
 
roemelboemelCommented:
with the SFU NFS Client on windows you have the mount command which has the "fileaccess" option to specify the mode which new iles get assigned.
mount -o fileaccess=<mode>

Open in new window

0
 
ToshiBoyCommented:
Also ensure that you are not mounting with the no_root_squash option checked. You should find that option in your exports or xtabs file. If this option is set all users are mapped as root, giving you the 500, root status. With it unset, you should get the mapping as Wesly Chen explained up there.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now