Solved

How to set datasource to application's path for xml file with Crystal Report?

Posted on 2011-03-23
8
918 Views
Last Modified: 2012-05-11
Hello,

Usually when I want my report to access the data source, I set the file's path as Same as Report and it works ok, however when using xml as a data source, it doesn't work, it wants a specified path even when I select same as report, any ideas how to fix this problem?

Thanks,

Victor
0
Comment
Question by:vcharles
  • 4
  • 3
8 Comments
 
LVL 100

Expert Comment

by:mlmcc
ID: 35203201
Where are you seeing the same as report?

What version of Crystal?

I wrote lots of reports with XML files as the source for a project.  WHat we did was specify a specific directory to keep the XML files in.  They were generated by the application after the user specified the filtering cirteria.  In that way there was never a need to change the data source.

mlmcc
0
 

Author Comment

by:vcharles
ID: 35203745
Hi,

I am trying to set the path to "Same as Report" from the Set Data Cource Location under the properties option which contains the following options: Database Type, Internal Connection and FilePath:

I need to be able to install the application to any folder, thast is why I  need the report to access the xml file from the installation's path.

Thanks,

Victor
0
 

Author Comment

by:vcharles
ID: 35203765
Forgot to mention, when I click on "Same as report" as receive a dialog box with the following option:

File Path:

Class Name

Use Dataset from class

Victor
0
ScreenConnect 6.0 Free Trial

At ScreenConnect, partner feedback doesn't fall on deaf ears. We collected partner suggestions off of their virtual wish list and transformed them into one game-changing release: ScreenConnect 6.0. Explore all of the extras and enhancements for yourself!

 

Accepted Solution

by:
vcharles earned 0 total points
ID: 35203796
It's working, I included the file's name in the File Path: textbox and copied the report and xml file to a new folder and it worked.

Thamks,

Victor
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 35203810
Great.  I thought that option had disappeared and at that time was only really useful for Access and other similar PC databases

mlmcc
0
 

Author Comment

by:vcharles
ID: 35295893
Please close this case. I figured out the solution.
Thank You.
0
 
LVL 100

Expert Comment

by:mlmcc
ID: 35688023
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0

Featured Post

Is Your AD Toolbox Looking More Like a Toybox?

Managing Active Directory can get complicated.  Often, the native tools for managing AD are just not up to the task.  The largest Active Directory installations in the world have relied on one tool to manage their day-to-day administration tasks: Hyena. Start your trial today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hot fix for .Net Crystal Reports 10.2.3600.0 to fix problems with sub reports running on 64 bit operating systems ISSUE: Reports which contain subreports fail with error "Missing Parameter Value" DEPLOYMENT SERVER OS: Windows 2008 with 64 bi…
Hello everyone, Hope you find this as helpful as we did. We have on the company I work for an application built in Delphi V with Crystal Reports 8. We all know that Crystal & Delphi can be temperamental sometimes and the worst thing is, nearly…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

825 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question