Solved

Getting error when accessing localhost on win XP IIS, "You are not authorized to view this page"

Posted on 2011-03-23
4
391 Views
Last Modified: 2013-11-19
I installed IIS on my Windows XP computer and typed localhost on internet explorer and it gave me a login box prompting me to enter user name and password. I am logged in to windows as administrator though. I enter username and password but it keeps asking for the same information. I hit cancel button and got the following error message;

You are not authorized to view this page
You do not have permission to view this directory or page using the credentials you supplied.
Please try the following:
Click the Refresh button to try again with different credentials.
If you believe you should be able to view this directory or page, please contact the Web site administrator by using the e-mail address or phone number listed on the localhost home page.
HTTP 401.2 - Unauthorized: Logon failed due to server configuration
Internet Information Services
Technical Information (for support personnel)
Background:
This is usually caused by a server-side script not sending the proper WWW-Authenticate header field. Using Active Server Pages scripting this is done by using the AddHeader method of the Response object to request that the client use a certain authentication method to access the resource.

Please help resolve this problem.
0
Comment
Question by:uzairp
  • 2
4 Comments
 
LVL 19

Expert Comment

by:Rikin Shah
ID: 35204552
Go to Run > inetmgr > Web Sites > Default Web Site > Properties > Directory Security > Edit > Uncheck "Integrated Windows Authentication"

and then try to access.
0
 
LVL 5

Expert Comment

by:zazagor
ID: 35206507
Hi,

Try to modify user/access rights on the fil/folder whre the default web site resides.
Try adding everyone --> full control

//zaZagor
0
 

Author Comment

by:uzairp
ID: 35212592
Did what rikin_shah suggested and tried again, it still gives me a login window - no change.

zazagor:I went to file explorer and selected 'inetpub/wwwroot'-> properties -> unchecked read-only property of the folder -> OK.
Is this what you wanted me to try or is it something else? please explain.
Any other suggestions!
0
 
LVL 19

Accepted Solution

by:
Rikin Shah earned 500 total points
ID: 35212763
Can u tell who are the members in your "wwwroot properties" - security tab?

There should be-
1. Everyone with Read & Execute, List Folder Contents, and Read rights
2. Users (Machinename\Users) with above permissions
3. VS Developers (Machinename\VS Developers) with above & Modify and Write permissions
4. Launch IIS Process Account (MachineName\IWAM_...) with Deny Write permission
5. Internet Guest Account (MachineName\IUSR_...) with Deny Write permission

Check these and try to access.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Read about why website design really matters in today's demanding market.
I've been asked to discuss some of the UX activities that I'm using with my team. Here I will share some details about how we approach UX projects.
The viewer will learn how to count occurrences of each item in an array.
The viewer will learn how to look for a specific file type in a local or remote server directory using PHP.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now