Solved

Exchange 2010 BPA on Edge Server Error

Posted on 2011-03-24
1
867 Views
Last Modified: 2012-05-11
Hi,

I have run the BPA on an 2010 exchang edge server and I am getting the following:

Incorrect kerbauth.dll loaded. The kerbauth.dll module loaded in IIS points to an incorrect location: 'C:\Program Files\Microsoft\Exchange Server\V14\Bin\kerbauth.dll'. It should point to '%EXCHBINPATH%\Bin\kerbauth.dll'.

I have this error for both my hub role servers from the edge servers, but if i run the bpa on the hub servers i get no error.

I have found:Microsoft Solution

But from what I can see this is setup correctly.

Any help would be great.

Thanks.
0
Comment
Question by:Colchester_Institute
1 Comment
 
LVL 11

Accepted Solution

by:
sighar earned 500 total points
ID: 35205693
I get the same error and cannot see that anything's out of the ordinary like you. I thought of reregistering the dll but haven't gotten around to it.

 I found this though at http://social.technet.microsoft.com/Forums/vi-VN/exchange2010/thread/efe35658-72b3-4625-aa89-31b182e2a05e:

-KERBAUTH should only be registered in IIS under modules on the PowerShell Site (not at the Default Site, and not at the Server level)
-KERBAUTH should only be registered as NATIVE, not as Managed at the PowerShell Site in IIS
-KERBAUTH should only be registered directly at the PowerShell Site in IIS, not Inherited.

If the Kerbauth.dll is registered as a "Managed" module not a "Native" Module, do the following:
• Remove Kerbauth from the Powershell web site as a Managed Module
• Verify if Kerbauth.dll is in the C:/Program Files/Microsoft/Exchange/V14/BIN directory.  
• In IIS go to the server level and register Kerbauth.dll using the name "Kerbauth" and the path to  C:/Program Files/Microsoft/Exchange/V14/BIN/KERBAUTH.DLL
• Go back to the Server level in IIS and Remove Kerbauth.  
Note: We are simply removing it from the server level, and since it is registered now, it should be available at lower levels.
• Under IIS Powershell in MODULES select Manage Native Modules, and check by Kerbauth which now should appear.
• Ran IISRESET from a Command Prompt
• Try opening EMC and EMS again.

2) Check to see if the Default Web Site has HTTP Redirect setting enabled, by selecting Default Web Site on IIS, and expanding “HTTP Redirect”.
If it is enabled, try the workaround of selecting the option under “Redirect Behavior”:

“Only redirect requests to content in this directory (not subdirectories)

Note:  By default the HTTP Redirect is disabled.
0

Featured Post

Too many email signature changes to deal with?

Are you constantly being asked to update your organization's email signatures? Do they take up too much of your time? Wouldn't you love to be able to manage all signatures from one central location, easily design them and deploy them quickly to users. Well, you can!

Join & Write a Comment

Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now