Solved

Wireless Config on Cisco 857w Router

Posted on 2011-03-24
2
851 Views
Last Modified: 2012-06-21
Hi all,

Im having some difficulty setting up my wlan on my Cisco 857w router. The host appears to connect to the WLAN, but  it is never able to retreive a valid ip address.

Can someone please check the below config and advise where im going wrong?

 
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
no aaa new-model
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool sdm-pool1
   import all
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   dns-server 203.12.160.35 203.12.160.36
!
!
ip cef
ip domain name tpg.com.au
ip name-server 203.12.160.35
ip name-server 203.12.160.36
!
!
crypto pki trustpoint TP-self-signed-1526081385
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1526081385
 revocation-check none
 rsakeypair TP-self-signed-1526081385
!
!

[Output excluded]

!
!
username username privilege 15 secret 5 password
!
!
!
bridge irb
!
!
!
interface ATM0
 no ip address
 ip mask-reply
 ip directed-broadcast
 atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 description TPG
 ip mask-reply
 ip directed-broadcast
 no snmp trap link-status
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 1 mode ciphers tkip
 !
 ssid Switched
    vlan 1
    authentication open
    authentication key-management wpa
    wpa-psk ascii 0 cisco123
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 station-role root
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Dialer1
 description TPG
 ip address negotiated
 ip mask-reply
 ip directed-broadcast
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication pap callin
 ppp pap sent-username username@isp.com password 0 password
!
interface BVI1
 no ip address
!
ip default-gateway 10.10.10.1
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip http server
ip http authentication local
ip http secure-server
ip nat inside source list 101 interface Dialer1 overload
!
access-list 101 permit ip any any
!
control-plane
!
bridge 1 route ip
!
line con 0
 login local
 no modem enable
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler max-task-time 5000
end

Open in new window


Thanks in advance.

Lev
0
Comment
Question by:lsenel
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
2 Comments
 
LVL 15

Accepted Solution

by:
Frabble earned 500 total points
ID: 35206620
You need the IP address on the bridge-group virtual interface:

interface Vlan1
 no ip address 10.10.10.1 255.255.255.0
 no ip nat inside

interface BVI1
 ip address 10.10.10.1 255.255.255.0
 ip nat inside

For completeness you should also confiigure the spanning tree protocol:

bridge 1 protocol ieee
0
 

Author Closing Comment

by:lsenel
ID: 35228093
Thanks Frabbie,

I updated the config as per your info and all appears to be working well now.

Appreciate your help with this.

Cheers,

Lev
0

Featured Post

Database Solutions Engineer FAQs

In this series, we will discuss common questions received as a database Solutions Engineer at Percona. In this role, we speak with a wide array of MySQL and MongoDB users responsible for both extremely large and complex environments to smaller single-server environments.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Working settings for French ISP Orange "Prêt à Surfer" SIM cards for data connections only. Can't be found anywhere else !
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…
Suggested Courses
Course of the Month10 days, 21 hours left to enroll

628 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question