• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 655
  • Last Modified:

New Active Directory deployment, can't ping hostname withough FQDN

Hello,

I just completed building our company's AD environment.  We are using Win2k8 R2 for both DC1 and DC2.  Both DCs are running DNS.  My laptop is issued an IP from the DHCP server running on DC1.  I can ping DC1 by the command "ping dc1.mycompany.local" and "ping dc1", but doing the same for antother domain computer only works if I use the full name, ie "ping servername.mycompany.local"  Issuing the command "ping servername" doesn't even return an IP address.  I have verified that there is an A record in DNS for servername, and it is pointing to the correct IP address.  Help.

ED7
0
electricd7
Asked:
electricd7
  • 3
  • 3
1 Solution
 
willettmeisterCommented:
You may have a search suffix issue.  Am I correct in assuming that all of these systems are joined to the new domain?  If you open you NIC properties and look at the DNS tab how are the settings configured for search suffixes(the settings about half way down the tab).

0
 
electricd7Author Commented:
My dns tab shows obtain automatically, then under advanced settings shows DNS server address box as empty, "Append primary and connection specific DNS suffixes" checked, "Append parent suffixes of the primary DNS suffix" checked, and "register this connections addresses in DNS" checked.  that is it.
0
 
willettmeisterCommented:
Please confirm that all machines are joined to the mycompany.local domain.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
electricd7Author Commented:
Oh sorry, my machine (the machine doing the pinging) is not joined to the domain, but is getting DHCP and DNS from the domain.
0
 
willettmeisterCommented:
Then thats your problem.  it's not appending the dns suffix because it has no suffix to append.  On the advanced DNS settings tab change the setting to append the these dns suffixes and add mycompany.local to the box below that radio button.  Alternatively join your machine to the domain.

Since you are in a workgroup or a different domain your machine doesn't know to append mycompany.local to servername and therefore has no idea how to look up the machine in DNS.
0
 
electricd7Author Commented:
Duh....you are 100% right, I tested.  Thanks! :)
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now