• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 406
  • Last Modified:

Directory Browsing for Apache 2.2.14 not working.

I have several sites hosted and need to enable directory browsing on one of them.  I have edited the .htaccess file in the site directory as attached.  The 2nd snippet is the apache2.conf file.  There is nothing in the httpd.conf file.  After adding the +Indexes we have restart the server and still can't get any listing on our /newsletter directory, just says that we don't have permission.
DocumentRoot "/home/os01/www"
ServerName www.os01.us
<Directory "/home/os01/www">
allow from all
Options +Indexes
ServerAlias os01.us
IndexOptions FancyIndexing HTMLTable

Open in new window

ServerRoot "/etc/apache2"

LockFile /var/lock/apache2/accept.lock

PidFile /var/run/apache2.pid

Timeout 300

KeepAlive On
MaxKeepAliveRequests 100
KeepAliveTimeout 15
<IfModule mpm_prefork_module>
    StartServers          5
    MinSpareServers       5
    MaxSpareServers      10
    MaxClients          150
    MaxRequestsPerChild   0

<IfModule mpm_worker_module>
    StartServers          2
    MaxClients          150
    MinSpareThreads      25
    MaxSpareThreads      75 
    ThreadsPerChild      25
    MaxRequestsPerChild   0

AccessFileName .htaccess

<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
DefaultType text/plain

HostnameLookups Off

ErrorLog /var/log/apache2/error.log

LogLevel warn

Include /etc/apache2/mods-enabled/*.load
Include /etc/apache2/mods-enabled/*.conf

Include /etc/apache2/httpd.conf

Include /etc/apache2/ports.conf
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent
ServerTokens ProductOnly

ServerSignature On
Include /etc/apache2/conf.d/

# Include the virtual host configurations:
Include /etc/apache2/sites-enabled/

Open in new window

  • 3
  • 3
  • 3
1 Solution
Does a index.htm or index.html exist at the document root?  If so, rename it.
Sorry didn't read the permission part, have you checked to make sure the directory has Apache permissions?
andygee1Author Commented:
At the document root meaning the root of the site, or the root of the folder that we want to be able to browse.  The site root does have a index, but the /newsletter folder does not have any index file, just pdf's and folders.
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

Check the permissions in /newsletter directory
it must be an equal as apache user, and owner`s permissions are rwx in directory

drwxr-xr-x 11 apache apache  504 Aug 7  2010 roundcube
andygee1Author Commented:
Newsletter directory permissions:

drwxrwxr-x 16 root    root    4096 2011-03-24 08:41 newsletters

Content within the newsletters directory has same:
drwxrwxr-x 3 root root 4096 2009-10-28 12:05 Det News 1997

remove .htaccess file and try again
andygee1Author Commented:
ok that worked for me.  Is there anything else I should do to it or is it ok to leave without the .htaccess file?
. htaccess needs to add the settings without changing the global server configuration.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Build your data science skills into a career

Are you ready to take your data science career to the next step, or break into data science? With Springboard’s Data Science Career Track, you’ll master data science topics, have personalized career guidance, weekly calls with a data science expert, and a job guarantee.

  • 3
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now