Hyper-V VM Hangs at login

Our server had a "fatal memory error" last night. Hard reboot was required to get it back up.

All our VMs are running but one of them hangs at "applying user settings" or it just logs you back out as soon as you log on.

I'm considering the reset option on the hyper-v manager? Can someone please explain this option to me and offer other directions?

Thanks!
LVL 1
Gig-A-DeeAsked:
Who is Participating?
 
msmamjiConnect With a Mentor Commented:
The reset option will reboot the VM. Just like the reset button in the physical machine. It will not shut it down cleanly. Think of it a plugging power out and back in.

I would advise to reboot the VM into safe mode (Reset the VM, click inside VM and press F8). Once logged on, have a look at event viewer, it will provide mode details about whats going wrong.

Regards,
Shahid
0
 
Gig-A-DeeAuthor Commented:
Many thanks. I booted into safemode, preformed a clean shutdown, rebooted and it's happy.

Do you recommend running chkdsk on the VM's drives after a hard shutdown?

Thanks
0
 
msmamjiCommented:
If you can afford the downtime. It wouldn't hurt. But I would rather recommend running it on the host machine physical disks as they are more prone to errors. VHDs are file on these pDisks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.