2.0 regiis - 'The application failed to initialize properly(0xc0000005).

I am getting a severe issue where I am unable to debug my 2.0 project anymore. It was working fine until i run an update today to be able to install silverlight.
I have got my application hosted on IIS 6.0 and using 2.0. I have got framework 1, 2, 3 and 3.5 installed on my machine.

I first got an error message "Failed to access IIS metabase." since i have once got this error message, i tried to run the aspnet_regiis.exe -i from command prompt but i end up with the error message:

'The application failed to initialize properly(0xc0000005). Click on ok to terminate the application

My antivirus has been disable and i was able to run aspnet_regbrowsers.exe without any popup error message.
I have also repair my .net 2.0 framework but still the same issue.

Yesterday i was able to use debugger without issue to to run my 2.0 thru debug mode but today i have done some updates and to have .Net framework 3.5 SP1 installed as requested by to have Silverlight3 installed.

Notice that my IIS has been reset and i have had to select ASP.NET 2.0 for my application which was already done before and also my machine.config file got reset my changes to it got by pass.

Read that removing  Symantec Endpoint solved the issue, can you kindly explain how? note also that thy antivirus is stopped

PLease help urgently
Who is Participating?
PrincemuhammadConnect With a Mentor Author Commented:
Was able to solve out this issue by using the .net fx cleanup tool and remove .net 3.5 and .net 2.0 and then reinstalled .net 2.0
PrincemuhammadAuthor Commented:
Download .net fx cleanup tool and remove required .net version
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.