Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4192
  • Last Modified:

SSRS Windows File Share Subscription

I have set up reports on my SSRS and have added subscriptions to generate and save reports down to a server shared folder.  In the subscription the credentials I'm using for the FileShare is a local server ID which has full rights to the folder\path specified.  This works fine as long as the local server ID i'm using is in the Admin group on the server.  If I take it out of this group and place in any other group I get this error:  An impersonation error occurred using the security context of the current user.
I just can't believe that to do this the ID has to have Admin rights on the server.  Is this true?
Thank You
0
DueFrom
Asked:
DueFrom
1 Solution
 
lcohanDatabase AnalystCommented:
Of course it has to do with that local ID being Local Admin on that server and I suggest before you switch it to another group either make sure that group has FULL read write rights to the "server shared folder" or at least that the local ID you are using has those rigts at the OS "server shared folder" level including all files/subfolders
0
 
DueFromAuthor Commented:
Yes, I gave that ID full rights to the shared folder and all sub folders.  But still get that error if that ID isn't in the local Admin group.  servername\id full control to folder/subfolders
0
 
lcohanDatabase AnalystCommented:
Hmmm...that must be from SSRS then - can you grant that ID rights to the Goup

SQLServerReportServerUser$ssrs_server_name_here$MSRS10.MSSQLSERVER
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
DueFromAuthor Commented:
These are the groups I have:

SQLServer2005DTSUser$servername
SQLServer2005MSFTEUser$servername$MSSQLSERVER
SQLServer2005MSSQLServerADHelperUser$servername
SQLServer2005MSSQLUsers$ServerName$MSSQLSERVER
SQLServer2005ReportingServicesWEbServiceUser$servername$MSSQLSERVER
SQLServer2005ReportServerUser$servername$MSSQLSERVER
SQLServer2005SQLAgentUser$servername$MSSQLServer
SQLServer2005SQLBrowserUser$servername

Are you talking about the 6th one?
0
 
lcohanDatabase AnalystCommented:
I would add it to both groups below as they are related to the SSRS:
SQLServer2005ReportingServicesWEbServiceUser$servername$MSSQLSERVER
SQLServer2005ReportServerUser$servername$MSSQLSERVER

0
 
DueFromAuthor Commented:
Added ID to those two groups, same error.
0
 
sureshbabukrishCommented:
Check http://msdn.microsoft.com/en-us/library/ms159264.aspx for some info on this.
The specific part that could solve the problem above is "the account that runs remote file share subscriptions requires rights to log on locally on the Reporting Services computer"


or check whether the password is expired or not?
0
 
DueFromAuthor Commented:
I added my ID to the Remote Desktop Users group on the server, so that way this ID can now log into the server itself.  But same error.   impersonation error occurred using the security context of the current user.
0
 
DueFromAuthor Commented:
I used this ID to log into the server, so I know the password is good as well.
0
 
lcohanDatabase AnalystCommented:
Is that ID added under the SSRS Report Security and generating the subscription? If you go to Report Manager under Report Properties there's a Security section and by default BUILTIN\Administrators are content manager so can you add that local ID as Content Manager as well?
0
 
DueFromAuthor Commented:
I do have a group called SQLReportingAdmins with Content Manager rights and this ID is in this group.  This ID belongs to this SQLReportingAdmins (has content manager rights), Remote Desktop Users and Users groups on the server itself.
0
 
lcohanDatabase AnalystCommented:
So if you go on that SSRS server, open SSMS and connect to Reporting Services, you can see that SQLReportingAdmins group under the Security and has same rights as ContentManager?
ContentManager.png
0
 
DueFromAuthor Commented:
ssrs local group local id
0
 
lcohanDatabase AnalystCommented:
Let's step back please and check the report(s) you have issues with in Repost Manager and make sure that the NT User or NT Group where it belongs exists under the report security. After that please check SSRS - Reporting Services Security in SSMS as I described above. All you posted is at the file/nt user/group level but what I'm talking about is the SSRS security connection to that user/groups.
ReportSecurity.png
0
 
DueFromAuthor Commented:
ssrs sql

I'm not sure when you say Report Manager and under report security.
0
 
lcohanDatabase AnalystCommented:
I meant screenprint4.gif as you posted above and as we can see you have that so...that just makes it more interesting. Did you tried to remove that security group from the report when the user is still in the Local Admin group, move the user into the local SQLReportingAdmins then add that group item back to the Report security lik in screenprint4.gif ?

If that group is live and has other users that the one you test/work with maybe just add that individual user to the report secutity as Content MAnager or create another group for testinmg purpose only.
0
 
DueFromAuthor Commented:
Sorry for the delay.  
I added the SSRSReporting server ID to the server Admin group, I scheduled the report and it saved to file share without issues.  I added the ID back to the local server group that has Remote Desktop rights and full rights to server shared drives - report generated correctly.  Took Id out of Admin local server group and report now gets the impersonation error.  

Do you know if the Excution Account within the Reporting Services needs to be setup? ssrs
0
 
DueFromAuthor Commented:
I was never able to get the subsciription service to work without the subscription ID used being in the administrators group on the server.   I think that maybe if your using the subscription to generate and save a file down, the ID used in that must be an administrator on the server.  But Icohan had many great suggestions to try, so will close on that note.  Thank you.
0
 
lcohanDatabase AnalystCommented:
http://msdn.microsoft.com/en-us/library/ms181156.aspx

"Setting this account is optional, but not setting it limits your use of external images and connections to some data sources"
0
 
beeramgopiCommented:
Hi,

I am also having same problem. I am trying to post a file from Server A to Server B using windows filesharesubscriptions.  The account (ABC) I am using to post the file has access to shared folder on Server B, is an administrator on both Server A and B. But I am still getting Impersonation error. Please advise what needs to be done.
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now