• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1112
  • Last Modified:

Asterisk finds server unreachable

Wouldn't you know it I tested the last solution for 5 days then as soon as posted the accepted solution the problem came back. This question is the same as my previous question. Somehow or other after being connected for maybe 2 days asterisk finds the VoiP provider server unreachable, which is then fixed by power cycling the modem. The funny thing is the connection lasts longer with 1 router over the other. It happens with 3 routers. The same as before, when the connection is down I can ping the server using the server name not the ip address so I know it's resolving. I'm using the same NAT traversal method, namely specifying the externip= xx.xxx.xxx.xxx and  localnet=192.168.0.0/255.255.255.0 in the config file. Once it goes down it does not come back.
0
Jeff swicegood
Asked:
Jeff swicegood
  • 10
  • 4
  • 2
1 Solution
 
API_NOCCommented:
Have you tried putting your server into the DMZ of your network?
0
 
Jeff swicegoodAuthor Commented:
I have a double NAT, one in the modem and one in the router. If I put the server in the DMZ of the router, would I also need to put the router in the DMZ (if it has one) of the modem?
0
 
feptiasCommented:
Sorry to hear that you've still got the problem. You can ask for a refund of points if you want.

To answer your DMZ question, the modem most likely just passes everything through to the router - so a DMZ would only make sense in the context of the router.

I wonder if it could be some kind of connection/session timeout. Are there any settings for session timeouts on the router? If so, the timeout for UDP connections is the relevant one (it is used by the stateful packet inspection engine). Try increasing it by about 50%. If there are settings to limit the maximum number of sessions, make them a little more generous.

Another idea: Check the settings on the firewall that are designed to protect it from attacks such as Denial of Service, UDP Floods, etc. Experiment with disabling them for a while to see if they make a difference.

Do you have access to the setup forms on the modem? If so, does it have settings for connections or sessions like those mentioned above?

A final idea: Next time you get the problem, try disconnecting the router from the modem for 5 minutes - just unplug the patch lead, but don't power cycle the modem. When you reconnect the patch lead, does it fix the problem or do you have to power cycle the modem.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
API_NOCCommented:
Put the router into the DMZ of the modem. Then the asterisk server in the DMZ of the router.
0
 
Jeff swicegoodAuthor Commented:
Thanks for all your leads. I am in the process of testing. I'll get back to you in a few days.
0
 
Jeff swicegoodAuthor Commented:
Yes, disconnecting the router from the modem for 5 mins restored the connection and fixed the problem.
0
 
feptiasCommented:
That's interesting. It points to an issue with established router connections - disconnecting the modem would force the router to clear its list of established connections. Next time, try a very brief disconnection of the patch lead. In my opinion it points much more to a router issue than a modem issue, but its a tough one to pin down.

Did you find any settings for sessions/connections etc?
0
 
API_NOCCommented:
Does the problem exists even when the DMZs are opened up?
0
 
Jeff swicegoodAuthor Commented:
I am just now setting the DMZ's and looking for session settings. I'll get back to you soon.
0
 
Jeff swicegoodAuthor Commented:
I set the DMZ's and I did find a setting for UDP timeout. I increased it from 120 sec to 180 sec. I did not find a setting for maximum sessions, but I did find one for maximum ports, but it was already at maximum.
0
 
Jeff swicegoodAuthor Commented:
Disconnecting patch cable for a short period did not restore the connection. Neither using the DMZ' nor the new UDP timeout settings helped.
0
 
Jeff swicegoodAuthor Commented:
Did you have any more ideas?
0
 
API_NOCCommented:
Can the modem in front of your router be put into bridge mode? This would allow the public IP to be on your router and then you can try the DMZ on the router.
0
 
Jeff swicegoodAuthor Commented:
I have attempted to put the modem in bridge mode, but I was not able to find enough information on the web. It is a Zyxel 660R. Maybe if I call my ISP they will help me do that.
0
 
Jeff swicegoodAuthor Commented:
The modem is now in bridge mode. I guess I will test it for a few days before putting the server in the DMZ.
0
 
Jeff swicegoodAuthor Commented:
Putting the modem in bridge mode, even without using DMZ has done the trick since my past post! I will test it for another week, then award full points.
0

Featured Post

Meet the Family that is Made for Collaboration

The TeamConnect Family product group as part of the Sennheiser for Business Portfolio comprising high-quality, technically well-conceived meeting solutions for business communication – designed for any meeting room and any meeting situation.

  • 10
  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now