Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 910
  • Last Modified:

VMWARE setup for lab testing

I cannot figure out this damn VMWARE networking stuff for workstation.

Gateway (192.168.1.1)
Desktop (192.168.1.4)
1 - 2008-DC/DNS (192.168.1.130)
2 - 2008-DHCP (192.168.1.140)

Cannot get DHCP to ping or access DC.

I spent a day with the VMware Network in a combination of Bridged / NAT / Host

I believe I can get the system to work in host only environment as the network is closed off. However I was really hoping to be able to remote desktop to the server via my actual desktop.

Anyway, any advice would be helpful. Trying to study for 70-642
0
UltraFlux
Asked:
UltraFlux
  • 7
  • 4
  • 4
2 Solutions
 
atigrisCommented:
You will need to disable VMware Workstation DHCP Service; This is an option on the VMware workstation virtual Networking. Once it's stopped then you will be able to use your windows server 2008 DHCP.

http://communities.vmware.com/message/1626594


0
 
Luciano PatrãoICT Senior Infraestructure Engineer Commented:
Hi

I think the problem here is not the same.

Do you have all that 4 machines in the Workstation as VMs? And you cannot ping any of that VMs from your workstation host? Is that the problem?

Or you cannot have DHCP IPs on your VMs?

Jail
0
 
UltraFluxAuthor Commented:
I haven't even been able to get the DHCP to join the domain, no communication via virtual machines.

So basically I am not really using DHCP at the moment, only static assignments on the DC / DHCP virtual machines.

STATIC
1 - 2008-DC/DNS (192.168.1.130)
2 - 2008-DHCP (192.168.1.140)

0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
UltraFluxAuthor Commented:
One Example:

DC (STATIC)
192.168.1.130
255.255.255.0
192.168.1.1 GATEWAY
192.168.1.130 DNS

Even with my host on 192.168.1.4 I cannot ping it, however I can ping 192.168.1.1

0
 
UltraFluxAuthor Commented:
Also when I test from the host computer, I can actually ping 192.168.1.130 which is the DC

Strange that I cannot ping from the DC to the host.
0
 
Luciano PatrãoICT Senior Infraestructure Engineer Commented:
Hi

Using the IP subnet from the host is the easy way. That is what you are using.

First check if the Windows firewall is not blocking your pings(from both sides, guests and host).

Second check this print screens a standard configuration for VMs in Workstation. And using static IPs on the VM side.

 Network Settings
 VM adapter Settings
Hope this can help

Jail
0
 
atigrisCommented:

Before fixing the DHCP issue; you need to make sure everything is accessible and can see each other

1. check that all of your VMs are one the same VMnet, check the NIC on each machine that is set on the same VMnet i.e VMnet0.

2. make sure you bridge or NAT all nics to make it all accessible on the subnet.  

3.  disable Windows Firewall on the DC, don't be dumb and disable the service from services.msc ? go to command prompt, type the following command:
netsh advfirewall set AllProfiles state off

or do it from the GUI

http://technet.microsoft.com/en-us/library/cc766337(WS.10).aspx


0
 
UltraFluxAuthor Commented:
testing above
0
 
Luciano PatrãoICT Senior Infraestructure Engineer Commented:
Hi

Also use a gateway from you outside VMs. Like a router, or you can use the IP from the host to work as a gateway, This sometimes fix some routing problems.

But with the configuration above, I have all my Workstation VMs working with the static IP and using my router IP for gateway.

Jail
0
 
atigrisCommented:
I think it would be better if you create an isolated network from your LAN for your Lab environment.
you may create another subnet 172.18.9.x for example for your Lab environment and use virtual router to route to your LAN network. This will prevent any DHCP/DNS conflicts and give you the chance to create full lab setup from A-Z.

You can do this by  creating a new VM that acts as a gateway with your LAN network. This can be accomplished by creating a VM with 2 Nics one points to your Virtual Network vmnet0 (LAN Network) and the other Nic points to your internal network (Lab) i.e vmnet4 which is configured as Host-only.

Then change the NICs on all VMs to point to vmnet4 instead of vmnet0. This will put all VMs on private network (Host-only) network.

Now only your Virtual router has access to internet because it has 2 Nics and one of them is connected to your vmnet0 which is your LAN network.

Now you will need a software that does routing so you can make all work. you can install Windows on this VM and use Routing and Remote access to create routing between the 2 NICs http://www.windowsnetworking.com/articles_tutorials/Configuring-Windows-Server-2003-act-NAT-router.html.  or you can install router such as vyatta.  http://www.vyatta.com/downloads/index.php

I found this very useful if you install VMware workstation on a laptop. you will be able to have internet access to your lab on any network you connect to down on the road. as you lab network is completely isolated.
0
 
UltraFluxAuthor Commented:
I really cant seem to get this even with your help. Feels like im spending hours on this VMWARE network stuff.

BestWay: Tried based on images provided

atigris:Before fixing the DHCP issue; you need to make sure everything is accessible and can see each other
exactly what I am trying to do

BestWay: I do use a router
My router ip is 192.168.1.1 and I have been trying to use it as the gateway
0
 
UltraFluxAuthor Commented:
So to recap.

Router = 192.168.1.1 (DHCP/DNS) however all systems are setup with static addresses.

Host = 192.168.1.5 (new Static IP for Host)
Win7 / All Firewalls Off

DC/DNS = 192.168.1.10 (new Static IP for DC)
netsh to turn off Firewalls

DHCP = 192.168.1.15 (not in the mix yet as I have not fixed the routing for the above)






0
 
atigrisCommented:
So you still able to ping your DC from your host computer?  but not the other way around?
and you said from your DC you can ping the gateway 192.168.1.1 ?

If so, it seems like the fierwall or software on your host computer blocking the connection. Please turn them off.  

Also we need you to post the current config of your network,

Your VMware NIC Setup
Your VMwar Virtual Networking mapping
What VMs can ping what and explain  the exact problems you are facing.

Take same printscreen of the VMconfig will be much better than writing them down.

Thanks
0
 
UltraFluxAuthor Commented:
Actually it seems to be working now. I am not sure perhaps the reboot that I made this morning helped everything out. Still a little confused why it did not work previously.

Regardless I am not connected by remoted desktop and starting training.

Current setup is all static ip addresses

Host - 192.168.1.5
DC - 192.168.1.10 (VMnet0) Bridged
DHCP - 192.168.1.20 (VMnet0) Bridged

Thanks for the help guys! I will split the points!
0
 
Luciano PatrãoICT Senior Infraestructure Engineer Commented:
Hi

For a normal configuration like that, bridged work just fine. Why use different subnet or NAT/route for just a VM??

Glade that you have fix the problem.

Jail
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 7
  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now