• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 426
  • Last Modified:

iPhone Exchange email problem

We have an SBS 2003 Standard Domain Controller and until recently were using Blackberry mobile phones for some staff. Email was being successfully sent to the BB's - this being configured using the BB website configuration (I think this is actually a 'pull' email setup).
We have recently purchased 2x iPhone 4.
It took some doing, but I was able to get Exchange to sync Outlook with these 2x iPhones using the EE article by alanhardisty, "Exchange 2003 - Activesync Connection Problems FAQ". This is a brilliant article and got it working after trawling the Internet for ages and failing repeatedly.
So, we are now getting email to the iPhones happily, but it only works while out of the office where the SBS server lives. When the iPhones are out of the office they connect to the Internet via the 3G mobile connection and they sync with Exchange fine, but while in the office they connect to the in-house wireless LAN as well and then they won't sync. As soon as they go out of range of the wireless LAN they start to sync again.
So there must be a setting or something somewhere that I have overlooked.
Any suggestions?
Greg
0
gregmiller4it
Asked:
gregmiller4it
  • 7
  • 5
1 Solution
 
hallcomisCommented:
Activesync uses port 443.  Is that port open on your wireless network?
0
 
Alan HardistyCo-OwnerCommented:
0
 
gregmiller4itAuthor Commented:
Um...I'm not sure. The wireless LAN is provided through the Netgear DG834G ADSL2+ modem/router, which also provides the firewall. However, I thought that the firewall really only sat between the Internet and the LAN and the wireless LAN was actually inside the firewall.
Any idea how I can test the state of the port across the wireless LAN?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Alan HardistyCo-OwnerCommented:
The port is not relevant - DNS is your problem and the lack of being able to resolve the FQDN on your internal network using internal DNS.
0
 
gregmiller4itAuthor Commented:
So, are you telling me that it can't be done, because of DNS limitations?
0
 
gregmiller4itAuthor Commented:
woops! I missed your first post Alan, so I'll check it out and come back to you.
0
 
Alan HardistyCo-OwnerCommented:
Read the article - it explains what you need to do to make it work internally.

Alan
0
 
gregmiller4itAuthor Commented:
So, I have created the new Forward Lookup Zone as described in the article. What services do I need to restart to activate the changes? (I made the changes 1.5 hrs ago and it doesn't seem to work yet.)
Cheers,
Greg
0
 
gregmiller4itAuthor Commented:
Ok, so this one has been left waiting for a while...sorry. I have now rechecked the situation and am still having the same problem: the iPhones won't sync while connected through the internal wi-fi network.
Any further ideas?
Greg
0
 
Alan HardistyCo-OwnerCommented:
No probs - what is the FQDN you are using to connect Activesync with?

What does that resolve to internally when you use nslookup (from a command prompt) to resolve the name in DNS?
0
 
gregmiller4itAuthor Commented:
Hmmm...I think you are on the right track here, but how to resolve it????
The FQDN (I'm thinking you want to know what the 'Server' field is set to in the account setup on the iPhone) = local.mydomain.org

When I go to a PC inside the domain and run nslookup on the above I get this:

C:\Documents and Settings\Username>nslookup local.mydomain.org
DNS request timed out.
    timeout was 2 seconds.
*** Can't find server name for address 192.168.0.100: Timed
*** Default servers are not available
Server:  UnKnown
Address:  192.168.0.100

DNS request timed out.
    timeout was 2 seconds.
Non-authoritative answer:
Name:    local.mydomain.org
Address:  XXX.XXX.XXX.XXX (this is the external IP address)

I'm not sure if it is relavent, but when we setup outlook on a laptop, so that it can still access the Exchange server from outside the domain, we configure Exchange over HTTP. Inside the domain/network the server address in Outlook is servername.mydomain.local, but from outside the domain/network (i.e.in Exchange over HTTP) the server address is local.mydomain.org.

Now the iPhones' Exchange server is set to local.mydomain.org and this works from outside the domain/network, but does not work inside the domain/network. Do we need to somehow configure the server setting to be servername.mydomain.local in the iPhone for when it is inside the domain/network?

Or is there a problem with the way the Exchange server was setup in the first place?

Greg
0
 
Alan HardistyCo-OwnerCommented:
Okay - that is what is expected.

You need to configure DNS internally to resolve local.mydomain.org to point to the internal IP of your server - then it should be happy on Wi-Fi.
0
 
gregmiller4itAuthor Commented:
Thanks, it is working now...at last!
Cheers,
Greg
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now