I am running xp virtual machine on a mac book pro and not able to connect to internet -- I did it as NAT in virtual settings -- but still not able to connect to internet.

I am running xp virtual machine on a mac book pro and not able to connect to internet  -- I did it as NAT in virtual settings -- but still not able to connect to internet. It's on nat and vmware is installed
Who is Participating?
Mantas BrasiunasConnect With a Mentor Commented:
Try "Bridged Adapter".
Owen RubinConnect With a Mentor PrincipalCommented:
I assume you mean you are running a Virtual machine with XP? What virtual machine software are you using? VMWare? Parallels?

In Parallels, I have the best results with Bridged networking. HOWEVER, make sure you pick the proper network adapter. You can bridge to any of the active network connections, and if they change, you will need to change who you are bridged to. For example, if you are connected via an Ethernet cable, then select Bridged Networking: Built-In Ethernet. If you then switch to Airport, you will need to change that to Bridged Networking: Airport.

If in Parallels, you can find this connection choice by clicking on the small spider web at the bottom of the virtual machine window, right side, or under the hardware tab of settings, and select Network Adapter, and then select the active network. If not Network adapter shows, you can add one by pressing the + key and adding one (as long as the VM is not running.)

Assuming you have a proper DHCP server running on your network, set the XP to Obtain an IP automatically, and it will get its own address.

Note that because you can connect the VM to any adapter, it is possible to have the VM use Airport while the Mac uses Ethernet, or vise versa, for example. I often do this when plugged into Ethernet, leaving my VM running on Airport.

Note that because you can have different
trekrichConnect With a Mentor Commented:
Set it to bridged. Also install some AV Microsoft Security Essentials is good and turn on your updates as well. This is a windows machine after all!
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

KashConnect With a Mentor 2nd Line EngineerCommented:
if none else works. Use Auto option which normally works fine for me on VMWare.
Owen RubinConnect With a Mentor PrincipalCommented:
One other thought occurred to me. How are you connecting to the internet?  Be sure that the network setting of the VM software is set to the right network adapter you are using. For example, if you are using Airport and the adapter is looking at the wired network, it will not work. Both Parallels and VMWare have settings for pointing the virtual machine's network at the right interface.

Also, I assume you have a router between you and the internet, and it is giving DHCP addresses to machines on the network. I have seen people who are connected directly to the cable or DLS modem to get to the internet. If you are connected this way, remember that this modem will only give you one IP address, so the virtual machine will not get one. If this is the case, you will need to use Shared Network settings.

If your router does give multiple addresses, make sure that the Windows sofware is looking at the right place and is set to DHCP.
Kyle SantosCustomer RelationsCommented:
I've requested that this question be closed as follows:

Accepted answer: 251 points for MantasBrasiunas's comment https:#a35214350
Assisted answer: 83 points for trekrich's comment https:#a35396458
Assisted answer: 42 points for orrubin's comment https:#a35220144
Assisted answer: 83 points for innocentdevi comment https:#a37538465
Assisted answer: 41 points for orrubin's comment https:#a37541602

for the following reason:

This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
Owen RubinPrincipalCommented:
I disagree with the point distribution. I have contributed much more to this answer. The original answer for which you give the most points is terse and not well explained.  I would be much happier with an even split between answers.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.