Full backups with differential of sql databases not performing properly

Greetings,
 VMware 4.0, SQL 2008, Backup Exec 2010 R2
This is what is happening: I run my full backup of the sql database on Saturday morning. Right after that I backup the virtual machine (the vmdk file) which from what is happening is triggering again another full backup of the sql database. So when my differential runs on Monday I get the following error:
'The Backup Exec SQL Agent was not used to create the last full, differential, or log backup of this database. You must use the SQL Agent to run a full backup before you can run a differential backup or transaction log backup.'
What it's boiled down to is the Backup Exec SQL agent does the full but then the VM causes a full too (I think) making the SQL agent think on Monday that something else has taken a backup. I have confirmed with the SQL guy that no other backups or maintenance plans are running on the database server. This also NEVER happened when I was using Backup Exec 12.5.
I could change the selection order in Backup Exec to have the SQL full backup go AFTER the VM is backed up but then it seems like overkill. Not sure what to do. I do have a ticket in with Symantec but we've been playing phone tag for a few days now so I'd see if anyone else had this problem.

Thanks all,
BW

P.S. What happened to the Backup Exec zone? Couldn't find it to add it.
bwinkworthAsked:
Who is Participating?
 
lundnakCommented:
Sounds like GRT is the problem.  Unfortunately, this will probably need a Symantec Support person to fix it.
0
 
lundnakCommented:
Could you check your SQL Server error log and see if you seeing a log entry for the SQL Full Backup at the time that the vmdk backup is occurring?
0
 
bwinkworthAuthor Commented:
I checked the logs. It shows @ around 12:25am that Backup Exec is backing up the sql databases with the message of 'Database backed up. Then @ 12:30am it starts with another message stating:
'I/O is frozen on database <databasename>' then
'I/O was resumed on database <databasename>'
The jobs don't over lap. It only takes Backup Exec about a minute to back them all up and then the VM gets backed up a few minutes later but it seems like it's resetting the databases somehow and messing up my differential on Monday-Thursday

Thanks,
BW
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
lundnakCommented:
This is a stretch, but is the Backup Exec job configured to do a Copy-Only full backup?  Do you transaction log backups have the same issue as the differential backups?
0
 
bwinkworthAuthor Commented:
Ah I looked a little farther in the logs and found that while the VM is being backed up there are a bunch of database entries that state:
'Database backed up. Database <databasename>, creation date.......blah blah blah device information: (FILE=1, TYPE=VIRTUAL_DEVICE: {big long number} This is an informational message only. No user action is required'
So the VM is backing up the databases. But in the settings of the backup job on the vmware settings I have disabled GRT for sql databases.
What a pain
0
 
bwinkworthAuthor Commented:
The settings for the vmware stuff is set to 'Full' (that's the only setting there is)
See picture

Thanks lundnak
backup-settings.JPG
0
 
bwinkworthAuthor Commented:
Ok that's what I thought. I'll let ya know how it goes. The guy is supposed to be calling me today
Thanks again
BW
0
 
lundnakCommented:
Check out this article.
Did you click the Edit button to look at the individual application items?
0
 
bwinkworthAuthor Commented:
Can't see the article in your post :)
0
 
bwinkworthAuthor Commented:
Ah thanks. Yes I've got that all disabled. Just weird that I can't be the only one having this problem lol. I've googled for hours
Oh well I'll see what the symantec guy says. I'll keep you posted.

BW
0
 
bwinkworthAuthor Commented:
Symantec's answer was to change the resource order so that the VM is backed up first and then have the sql full backup run right after it which is what I had done on Friday myself. But I had another failure on the weekend about my 2nd tape not being an LTO4 type tape so it quit lol. Yes it is an LTO4 because I've used it before.
Anyway thanks for the help fella.

BW
0
 
lundnakCommented:
Unfortunately, that is not a great solution.  It seems like Backup Exec shouldn't backup the SQL Server if it isn't checked.

Any way, glad that it is working now.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.