Windows 7 Resource Monitor without Administrator Rights

Hi,

I want to give access  to non-admin users to the Resource Monitor in Windows 7 or server 2008 r2.

the button on the performance Tab of Task Manager ask for an elevation privilege.

I try the groups Performance Monitor Users and Performance Log Users but this give access only to Perfmon.exe not to Perfmon.exe /res.

if you are member of these 2 groups you can open Perfmon but you can't click on the "Play button" on the bar.

you can add counter and check the performance monitor but you can't have the global view of Resource Monitor without Elevating privilege to Administrator users.

I can't give the local Adminitrator rights on my server or workstation, but I want people to be able to use Resource Monitor View.

someone can help me with this?

thanks
bluberiAsked:
Who is Participating?
 
xylogConnect With a Mentor Commented:
Have you tried "Profile System Performance" privilege under User Rights Assignment in Local Security Policy? Run secpol.msc then look under Local Policies -> User Right Assigments
0
 
Randy DownsOWNERCommented:
You might create a runas batch file that you execute from a shortcut - http://www.techimo.com/forum/technical-support/90867-running-exes-run-bat-file.html

Runas command prompts for a password, which is a problem as non of us wants to give out admin passwords to our users. But I found a way around that problem:

runas /user:domain\username \\server\folder\setup.exe | sanur password

The sanur command allows you to script in the password for the admin userid used in the runas command - pretty cool. Download the sanur.exe and place it in the same folder as the script. Check out http://www.commandline.co.uk/sanur for more details.

0
 
bluberiAuthor Commented:
thanks for the answer... this is not a way my boss like me to use...

I was searching for a restricted privilege group, registry tweak or giving full rights on the good folder to make the executable starts...

maybe the only way is to give administrative rights to the users. :(

because the sanur option is no longer supported too. if someone came up with another solution let me know.

thanks
0
 
bluberiAuthor Commented:
Thanks xyloq it was a good idea but finally it doesn't work either...

and finally we will not try to make it work. the time spent on this problem versus the utility is not valuable.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.