Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

How to properly configure RIP when WAN interface is DHCP

Posted on 2011-03-25
8
1,151 Views
Last Modified: 2012-05-11
I have a Cisco 1841 connected to my ISP with the WAN port configured for DHCP.  I have a /30 subnet with public addresses (no NAT) configured on my LAN port.  I'm having trouble configuring RIP to advertise this local subnet to my ISP's upstream router.  I'm getting an IP from my ISP and from the router console I'm able to ping a host on the internet, however I'm unable to communicate with any host beyond my local 1841 router if attempted from a host on the LAN. The same solution works fine on a smaller residential  Linksys router with minimal effort.  Below is my current config.  Any help would be greatly appreciated.

interface FastEthernet0/0
 description LAN
 ip address 69.x.x.x 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description WAN
 ip address dhcp
 duplex auto
 speed auto
!
router rip
 redistribute connected

Open in new window

0
Comment
Question by:etcit
8 Comments
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 35216223
Hi,

Only that you need to add route fast 0/1 interface:

ip route 0.0.0.0 0.0.0.0 fast 0/1
0
 
LVL 3

Expert Comment

by:FWeston
ID: 35216544
ikalmar is correct.  RIP should provide a route, but I haven't seen any ISP use RIP in ages.  Usually they'll have a static route pointed to your WAN address for your /30 and you would just need to add a static default route as ikalmar has suggested.
0
 

Author Comment

by:etcit
ID: 35216787
The default route is provided by my ISP via DHCP.  I know this is working because I'm able to communicate with hosts on the Internet from my router's console.  The reason for using RIP is due to the fact that the IP address on my router's WAN port is dynamic.  My ISP would have to update their static route any time the WAN IP on my router changes.  This scenario has worked flawlessly for months now over my Linksys router by simply enabling RIP.  I'm just looking to perform the same function with my $1000 Cisco 1841 that my $40 Linksys is doing :) I'm just missing something in my RIP configuration.
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 35216860
Please show:

sh ip route
sh ip proto
0
 

Author Comment

by:etcit
ID: 35217048
#sho ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 24.239.16.1 to network 0.0.0.0

     69.0.0.0/30 is subnetted, 1 subnets
C       69.85.108.128 is directly connected, FastEthernet0/0
     172.16.0.0/32 is subnetted, 1 subnets
S       172.16.254.6 [254/0] via 24.239.16.1, FastEthernet0/1
     24.0.0.0/20 is subnetted, 1 subnets
C       24.239.16.0 is directly connected, FastEthernet0/1
S*   0.0.0.0/0 [254/0] via 24.239.16.1


#sho ip proto
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 0 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: connected, rip
  Default version control: send version 1, receive any version
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: (default is 120)

Open in new window

0
 
LVL 17

Expert Comment

by:MAG03
ID: 35218281
you could issue the command default-information originate on your 1841 router under the rip process. This will tell all other neighboring rip processes to send traffic for unknown networks to that router.
0
 

Accepted Solution

by:
etcit earned 0 total points
ID: 35244558
I was finally able to get this working.  Below is the working RIP config that I've deployed for anyone that may encounter this problem in the future.

router rip
 version 2
 redistribute connected
 network 0.0.0.0
 default-metric 1
 no auto-summary

Open in new window



The key was the network 0.0.0.0 line.  This enables RIP advertisements on all interfaces.  If you want to suppress RIP messages on other interfaces just add passive-interface ifnumber to the RIP configuration.  Thanks everyone for your assistance.
0
 

Author Closing Comment

by:etcit
ID: 35308465
Tried other suggestions but finally arrived at solution through my own testing efforts
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Network ports are the threads that hold network communication together. They are an essential part of networking that can be easily ignore or misunderstood, my goals is to show those who don't have a strong network foundation how network ports opera…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

792 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question