Solved

sharepoint foundation setup auto login

Posted on 2011-03-25
17
1,190 Views
Last Modified: 2012-05-11
Hi

I have setup sharepoint foundation 2010 and need some assistance getting users to be able to login automatically.  We are running AD on our network.  I set this up a long time ago on WSS 3 but can't remember how to do it.

thanks,
0
Comment
Question by:bains1000
  • 8
  • 8
17 Comments
 
LVL 7

Expert Comment

by:saastech
Comment Utility
Enable Anonymous Access in SharePoint 2010


1.  Open Sharepoint 2010 Central Administration Webpage
2.  Select Manage Web Applications
3.  Select Site you want to modify permissions for
4.  Select Authentication Provides button from Ribbon menu
5.  Click on Default
6.. Checkmark box  Anonymous Access
7.  Go back to Manage Web Applications in the Central Administration
8.  Select Anonymous Policy Button in the Ribbon Menu
9.  Select your Zone and select Anonymous User Policy to NONE.  
10. Now, goto your SP site, navigate back to the Top Level
11.  Under Permissions Tools , Choose Anonymous Access and set the permission for the site.

you can refer to the following link as well:

http://www.topsharepoint.com/enable-anonymous-access-in-sharepoint-2010
0
 

Author Comment

by:bains1000
Comment Utility
Hi

Thanks for this but i do not want users to have anonymous access as such, i would like the auto login with their AD account, i think from memory it was a kerberos settings i set on WSS 3.
 
0
 
LVL 16

Expert Comment

by:jessc7
Comment Utility
Is the SharePoint site in IE's Trusted Sites list?
0
 
LVL 16

Expert Comment

by:jessc7
Comment Utility
Additionally, is your web app Authentication Provider set to use Windows Integrated Authentication? (Either NTLM or Kerberos?)
0
 

Author Comment

by:bains1000
Comment Utility
Hi

I have added the site to trusted sites on the PC i am using to test, but it still prompts me for login credentials, if i enter them it allows me to login and shows me as logged in as the respective user.

I have checked authentication in the following error:

1.  Sharepoint 2010 Central Administration Webpage
2.  Select Manage Web Applications
3.  Selected the site in question
4.  Select Authentication Provides button from Ribbon menu
5.  Click on Default
this is set to negotiate (kerberos)  I did try changing to NTLM but this did not work.  When I changed this back i received the attached message.  I have not changed anything in the application pool, do i need to make some changes?

thanks
applicationpool.JPG
0
 
LVL 16

Accepted Solution

by:
jessc7 earned 500 total points
Comment Utility
Have you set up all the SPNs and Delegations you need to have Kerberos configured correctly?

http://technet.microsoft.com/en-us/library/ee806870.aspx

The NTLM method does not require this level of configuration. If you switch it back to NTLM, are you able to use a web browser on one of the SharePoint servers and access a SharePoint without needing to manually log in? Do you have a specific requirement to use Kerberos?
0
 

Author Comment

by:bains1000
Comment Utility
no I haven't setup the SPNs.
soulds like NTLM might be the better option, i do not have any specific requirements to use kerberos, i just need the sharepoint site to login automatically.
I have switched it back to NTLM but it is still prompting me for a password?  Do I need to restart IIS?

thanks for your help so far.
0
 
LVL 16

Expert Comment

by:jessc7
Comment Utility
You shouldn't need to, but it wouldn't hurt anything. Are you testing the NTLM setup by using a web browser *not* on the SharePoint server?

There may be a loopback check involved preventing pass-through authentication via a web browser on the server itself, which can easily be disabled. See method #2:

http://support.microsoft.com/kb/896861

This wouldn't solve the issue if it is still occuring for a web browser on a machine other than the SharePoint server(s) however.
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:bains1000
Comment Utility
I am trying on the sharepoint server which is sitting on Server 2008 running IE8
I am also trying on Windows XP SP3 running IE7 on the same internal domain/network.

Something else i have just discovered, both machines are prompting for password, if I enter domain/username then password on XP PC, it will login and give me the team site page and will show we logged in as the user in the top right, however on the server itself, i just get the password box reappear (as if i had entered incorrect credentials) after a couple of attempts I get a blank internet explorer page, no error.
Both machines have the site in the trusted zone

Some other notes to help you understand how I have setup so far:
This is a new sharepoint setup (only the one server running sharepoint)
I have setup the URL as sharepoint.domain.local
I have added the entry into my DNS table so all machine on the network resolve the address to the server.  The server netbios name is not sharepoint.
0
 
LVL 16

Assisted Solution

by:jessc7
jessc7 earned 500 total points
Comment Utility
The issues with logging in on the server sound like the loopback issue. Follow method #2 in this KB and see if it resolves that issue:
http://support.microsoft.com/kb/896861

On the XP machine, can you try moving the entry for the URL from the Trusted Sites zone to the Intranet zone?
0
 

Author Comment

by:bains1000
Comment Utility
To add to the last point I have just tried browing to http://sharepoint and it logs in automatically however if I browse to http://sharepoint.domain.local I am prompted for a password, this is on the windows XP PC?

I am prompted for a password no matter what I browse on the server however if I browse to http://netbiosnameofserver it logs me in.

0
 

Author Comment

by:bains1000
Comment Utility
We are making progress now, the loop back change worked on the server, now when I go to http://sharepoint it allows me to login

Do you have any idea why on the XP machine when I browse to http://sharepoint.domain.local I get prompted for a password but not when I browse to http://sharepoint?

Thanks for your help so far.. I think we can see the finish line now :)
0
 
LVL 16

Expert Comment

by:jessc7
Comment Utility
Good news on the server side.

Can you add sharepoint.domain.local to IE's Intranet Security Zone on the XP machine and try again?
0
 
LVL 16

Assisted Solution

by:jessc7
jessc7 earned 500 total points
Comment Utility
I'm asking because the default setting for Automatic Login in IE is set to Intranet only (see image). You could also try the setting below that one for a less restricted permission.
screenshot.png
0
 

Author Comment

by:bains1000
Comment Utility
Jessc7 you are a genius, it has worked.  i will create a GPO to add the site for all PCs
Thanks you so much for your assistance tonight.
0
 

Author Closing Comment

by:bains1000
Comment Utility
Absolutely brilliant assistance and near instant responses!!

Thanks you for your help.
0
 
LVL 16

Expert Comment

by:jessc7
Comment Utility
Excellent! Glad it's all working. :) Enjoy the rest of the weekend...
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

I recently came across an issue with a MOSS 2007 deployment where access into some sub-sites were denied, even for the MOSS farm administrators. A bit of background to the setup of this MOSS farm; this was a three server setup, consisting of a fr…
We had a requirement to extract data from a SharePoint 2010 Customer List into a CSV file and then place the CSV file into a directory on the network so that the file could be consumed by an AS400 system. I will share in Part 1 how to Extract the Da…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…
You have products, that come in variants and want to set different prices for them? Watch this micro tutorial that describes how to configure prices for Magento super attributes. Assigning simple products to configurable: We assigned simple products…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now