Iphone Exchange ActiveSync mail only works with some Exchange 2010 mail accounts

We recently transitioned from Exchange 2003 to Exchange 2010. I can get ALL of our newly created mail accounts to work on the iPhone using the Mail on the iPhone. However, MOST (not all) of our old mailboxes, which were moved from Exchange 2003 to Exchange 2010 wil not work. The error I get is: 'Cannot Get Mail - The connection to the server failed'.
This applies to the Calendar, Contacts and all other folders in the mailbox; none of the will connect.

I should mention that we had never used iPhones before the upgrade from Exchange 2003 to Exchange 2010 so it may not have anything to do with this issue.

I've checked all settings and they are identical between the new and the old mailboxes.

Any suggestions?
mark-199Asked:
Who is Participating?
 
Alan HardistyConnect With a Mentor Co-OwnerCommented:
You may be missing the inherited permissions on the accounts or they may be Admin users and that can cause a problem.

Please have a read of my article for details of what will hopefully fix the problem for you:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2861-Activesync-Working-But-Only-For-Some-Users-On-Exchange-2007-2010.html
0
 
AustinComputerLabsCommented:
Under reciepient configuration
Mailbox
properties for the user
is exchange activesync enabled?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.