Solved

ASA cannot access resources in DMZ

Posted on 2011-03-25
3
414 Views
Last Modified: 2012-05-11
I cannot access a printer from Inside interface to the Wireless (DMZ) interface. The IP address is 192.168.2.24


User Access Verification

Password:
Type help or '?' for a list of available commands.
home-fw> en
Password: ********
Invalid password
Password: ********
home-fw# nat (wireless) 1 192.168.2.0 255.255.255.0
          ^
ERROR: % Invalid input detected at '^' marker.
home-fw# config t
home-fw(config)# nat (wireless) 1 192.168.2.0 255.255.255.0
home-fw(config)# access-list nonat permit ip 192.168.0.0 255.255.255.0 192.168$
home-fw(config)# access-list nonat permit ip 192.168.2.0 255.255.255.0 192.168$
home-fw(config)# nat (inside) 0 access-list nonat
home-fw(config)# access-list Wireless permit ip 192.168.0.0 255.255.255.0 any
home-fw(config)# sh ocnfig
                     ^
ERROR: % Invalid input detected at '^' marker.
home-fw(config)# sh config
: Saved
: Written by enable_15 at 13:59:51.069 EDT Fri Mar 25 2011
!
ASA Version 8.2(2)
!
hostname home-fw
domain-name bmtga.com
enable password GVvROF64A5RnidAT encrypted
passwd GVvROF64A5RnidAT encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.0.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Vlan12
 nameif wireless
 security-level 50
 ip address 192.168.2.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
 switchport access vlan 12
!
interface Ethernet0/2
 switchport access vlan 12
!
interface Ethernet0/3
 switchport access vlan 12
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa822-k8.bin
ftp mode passive
clock timezone EST -5
clock summer-time EDT recurring
dns server-group DefaultDNS
 domain-name bmtga.com
access-list Internet extended permit icmp any any
access-list Internet extended permit icmp any any echo-reply
access-list Internet extended permit icmp any any unreachable
access-list Internet extended permit icmp any any time-exceeded
access-list Wireless extended permit icmp any any
access-list Wireless extended permit icmp any any echo-reply
access-list Wireless extended permit icmp any any unreachable
access-list Wireless extended permit icmp any any time-exceeded
access-list Wireless extended permit ip 192.168.2.0 255.255.255.0 any
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu wireless 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-631.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
global (wireless) 1 192.168.2.190-192.168.2.199 netmask 255.255.255.0
nat (inside) 1 0.0.0.0 0.0.0.0
nat (wireless) 1 0.0.0.0 0.0.0.0
static (inside,wireless) 192.168.0.0 192.168.0.0 netmask 255.255.255.0
access-group Internet in interface outside
access-group Wireless in interface wireless
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto isakmp nat-traversal 30
telnet 192.168.0.0 255.255.255.0 inside
telnet 192.168.2.0 255.255.255.0 wireless
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.0.100-192.168.0.131 inside
dhcpd dns 4.2.2.1 4.2.2.2 interface inside
dhcpd enable inside
!
dhcpd address 192.168.2.100-192.168.2.130 wireless
dhcpd dns 4.2.2.1 4.2.2.2 interface wireless
dhcpd enable wireless
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
<--- More --->
0
Comment
Question by:Aeroquinn
  • 2
3 Comments
 
LVL 33

Expert Comment

by:MikeKane
ID: 35218497
Config looks ok at a glance....     Do you see anything in the syslog related to the IP?     Look at the ASDM log or "Show logging' from CLI during an attempt to connect.

Some basics:  
Can the ASA ping the printer at 192.168.2.24?
Does the printer have the correct default gateway?
0
 

Accepted Solution

by:
Aeroquinn earned 0 total points
ID: 35219427
The config was not correct. I figured it out. Thanks.
0
 

Author Closing Comment

by:Aeroquinn
ID: 35252824
I figured out the solution myself
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
SonicWALL SIP Transformation Problem 4 56
Shoretel QoS Configuration on Cisco Switches 9 43
RDP ISR4321 Cisco Router 7 23
Vlan extend across 2 switches 16 14
I found an issue or “bug” in the SonicOS platform (the firmware controlling SonicWALL security appliances) that has to do with renaming Default Service Objects, which then causes a portion of the system to become uncontrollable and unstable. BACK…
Use of TCL script on Cisco devices:  - create file and merge it with running configuration to apply configuration changes
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

24 Experts available now in Live!

Get 1:1 Help Now