• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 740
  • Last Modified:

Cannot Join Domain RPC Server Unvailable

I have a farily new SBS 2008 domain.  I cannot Join an XP pro machine to the domain. I have tried to use the connect computer feature via web and the change domain under system properties.  I get the same error "RPC server unavailable"  I have the SBS 2008 set up as the Primary and only DC.  It is configured within VMware ESXi.  I have no problem with DNS resolution.  

I have tried numerous things and have been researching fixes for days now... Can someone help me trouble shoot this please?

What additional information do you need?
0
Robjergat
Asked:
Robjergat
  • 8
  • 3
  • 3
  • +1
1 Solution
 
ajwukCommented:
Does the system time match on both the domain controller and the PC you are trying to join to the domain.
Also, have you tried using the FQDN for the domain? E.G. domain.local as well as just domain?

HTH.
0
 
ajwukCommented:
Also, as the SBS is virtual, have you got the network card configured in a bridged mode?
0
 
RobjergatAuthor Commented:
System time does match. I have the system setup to use DHCP and it is getting all of the correct infot(time). Yes, I have tried both domain.local and domain.  I have the dns suffix added in the NIC config as well as add when you join domain check box(in system properties).

I am not sure if the NIC is configured in bridged mode.  Do i look within the SBS environment or the VMWare environment to check this?
0
Get free NFR key for Veeam Availability Suite 9.5

Veeam is happy to provide a free NFR license (1 year, 2 sockets) to all certified IT Pros. The license allows for the non-production use of Veeam Availability Suite v9.5 in your home lab, without any feature limitations. It works for both VMware and Hyper-V environments

 
ajwukCommented:
The vmware configuration. Settings for the network card on the sbs vm.
0
 
bhartwellCommented:
Check and see if the "TCP/IP NetBios Helper" Service is started, if not give it a start and re-try adding to the domain. I've seen this help some people in the past get through similar issues.
0
 
TomislavjSystem AdminCommented:
have you checked did rpc service and it's dependencies start correctly? i had same problems and answer was to "force" automatic start of service with gpo
0
 
RobjergatAuthor Commented:
Thanks For the replies.  Gonna have to put this one on hold for now.  I suspect that i may be having some hard drive issues, so I am going to wipe and load on new hard drives and see if the issue still exists

ajwuk:  in regards to the NIC configuration.  I could not find where to reconfigure then NIC in the GUI.  I am using Vsphere for my GUI.
0
 
RobjergatAuthor Commented:
Ok I'm back at it now... I loaded a new PC and performed all of the updates.  I have re-checked the services.  The only one that is not started is the Computer browser.  It is set to automatic.  When I start it, it basically says that it doesn't have any work to do and stops.  I still receive the RPC server unavailable message when i try to connect to the domain.

I have looked through the configuration on the VM ESX server and can not find where you would bridge the NIC.  Please guide me to the right place to try this.
0
 
RobjergatAuthor Commented:
Bump
0
 
RobjergatAuthor Commented:
Can someone help please?  
0
 
bhartwellCommented:
Is the Workstation and Server services in the started state on the XP system? Make sure those are started, on the SBS server verify that there isn't a computer account already created for this XP pc, if there is, delete it and retry adding the XP pc to the domain.
0
 
RobjergatAuthor Commented:
Thanks Bhartwell... i resolved the issue a few seconds ago ...it was the server side firewall
0
 
bhartwellCommented:
Ahhh nice. Glad to hear you were able to resolve it.
0
 
RobjergatAuthor Commented:
Thanks
0
 
RobjergatAuthor Commented:
posted by RobWill


Generally when a computer cannot join the domain using http://connect (SBS 2008 & 2011) or http://SBSname/connectcomputer (SBS 2003) it is due to inability to correctly resolve the name of the domain controller in a timely fashion. Below is a list of common reasons for the connect wizards to fail. In an SBS domain the server should be the DHCP server, and if so, items 2 and 3 below should be automatically set through DHCP. However if addressing is statically assigned or you are using a router you may need to make changes. Items 2 and 3 are also basic networking requirements of a Windows Domain, not just important for joining the domain.

1.      If there is more than 1 network adapter installed , wired or wireless, disable all but 1, preferably wired, until after joined to the domain
2.      Make sure, using IPconfig /all, that the client's DNS points ONLY to your internal DNS servers, in this case the SBS. Do not allow a router or ISP to be added as an alternate.
3.      IPconfig /all should also show next to “Connection-specific DNS Suffix” your internal domain suffix (MyDomain.local). If not you need to add the domain suffix to the client machine. To do so insert it in the "DNS suffix for this connection" box under the DNS tab of the NIC's advanced TCP/IP IPv4  properties
4.      If there are any 3rd party firewalls or security suites installed, disable them until joined to the domain
5.      If still failing add the connect web site to the “trusted” sites list in Internet Explorer under Internet options / security
6.      On a few occasions Bluetooth accessories such as keyboards and mice have been known to interfere with the connect wizards. If necessary temporarily replace these with wired devices until domain joined.
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

  • 8
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now