Batch file won't work

Posted on 2011-03-25
Last Modified: 2012-05-11
I created a batch file to copy and past an access database from the server to the clients computers, but it does not do the job. Can someone tell me what is wrong with my batch file. Thanks!
The batch file is as follow:

@echo off
rem This batch file installs the Membership front-end (Access .MDB file) on the user's PC.
rem It runs from the server where the front-end resides.

xcopy "\\server_name\directory_from_the server\Membership.mdb" "C:\Membership\" /y /i
Question by:SambaCor
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
  • 2
  • +1
LVL 11

Expert Comment

ID: 35218662
try to use this instead:

net use x: "\\server_name\directory_from_the server\"
xcopy "X:\Membership.mdb" "C:\Membership\" /y /i

Open in new window


Author Comment

ID: 35218915
I tried your suggestion nordtorp, but that didn't do it either.
I forgut to mention that the file to be copied reside on a windows 2008 server. The client machines are running xp pro.
LVL 11

Expert Comment

ID: 35218987
An error message would certainly help us figure out what the problem is.

Do you have access to \\servername\sharename from the XPs? Can the user you logged in as access it and copy manually?

Also, I've had problems with copying databases when they're live, i.e. in use. Is that the case here?
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

LVL 11

Expert Comment

ID: 35219010
Try to turn on File and printer sharing on the server. You find it in Network and Sharing Center
LVL 21

Accepted Solution

CompProbSolv earned 500 total points
ID: 35219014
Can you try running the xcopy line at a workstation from a command prompt and report what the result (did it copy?  what messages did you receive) is here?

Author Comment

ID: 35219051
I don't get any error message.
Yes I have access to \\servername\sharename from the XPs.
Yes, I can copy the database and past it manually, no problem.
The database is not open.

I also hear of robocopy, would that be easier to use in my scenario? I have never use it before.
LVL 21

Expert Comment

ID: 35219088
You are saying that it runs fine if you just run the xcopy command, but not if you run the batch file, everything else being the same?

How are you running the batch file?  (on which computer, from run or cmd, or?)
LVL 11

Expert Comment

ID: 35219125
The robocopy command would be almost the same:

robocopy \\source \\destination

Author Comment

ID: 35219229
When I run xcopy from the command prompt I get the error: file not found.
But when I right click on the file and copy (from the shared drive), I am able to past it on the local machine.
I am running the batch file on the xp machine by just double clicking it. The batch file is a short cut on the desktop. But it is located on the shared folder on the server.

Author Comment

ID: 35219308
Sorry guys xcopy from command promt works fine, I didn't type it correctly.
The batch file is actually working now without the net use syntax.
I would like to give the points to CompProbSolv. And thak you to nordtorp for helping.

Author Closing Comment

ID: 35219318
It worked when I run it from the command prompt and I went from there.

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
How ldap located a Domain controller? 22 79
WannaCry ransomware worm 2008 and 2012 server 1 147
Utility to Scan for Unauthorized Access 4 38
Duplicate SPN entries 1 24
New Windows 7 Installations take days for Windows-Updates to show up and install. This can easily be fixed. I have finally decided to write an article because this seems to get asked several times a day lately. This Article and the Links apply to…
OfficeMate Freezes on login or does not load after login credentials are input.
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question