User Profiles win2008

Hi Experts -

I have a brand new win2008 server (roles = file and print services,  AD, dns dhcp).  There is going to be a second server holding terminal services in the domain too.  

When I add the new users to the server, I want to set their "default" Mydocuments folder to an area I have created on the server (D:\user_data).

Also when the users log in via terminal services they should map to the their default "My Documents on the server.

What is the best way to do both of these things.
martinmcginleyAsked:
Who is Participating?
 
rsoly777Connect With a Mentor Commented:
You would be looking at a Roaming Profile then,
For the general roaming profile, here is a step-to-step practice:

 

1. Prepare the roaming user profile

 

-      Log on to a Windows Server 2008 with the domain user account to produce a user profile. Log off the computer.

 

-      Log on to the Windows Server 2008 with a domain administrator account.

 

-      Click Start--->right-click Computer--->Properties--->Advanced System Settings--->Advanced--->User Profiles Settings…--->Settings--->Copy To. Copy the profile to the file server, such as '\\filesrv\profiles\username.v2'

 

Note: A ".v2" suffix to the name of the user profile folder on the file server must be added to distinguish between version 1 and version 2 profiles.

 

-      In Permitted to use, click Change. Type the proper users or groups and then click OK.

 

 

2. Prepare the user Profile path setting

 

-      In the Active Directory Users and Computers, type the profile location such as '\\filesrv\profiles\username' in the user's Profile path attributes.

 

Note: Do NOT add ".v2" to the Profile path of the user object. This indicates that for Windows Server 2008 it will load the profile from 'username.v2' folder and for former Windows operating systems they will load from 'username' folder if it exists.

 

 

 

If you manually create user profile folder, please check the NTFS and share permission on the roaming profile share folder.

 

-      Locate the roaming profile share folder, and check the NTFS permission to make sure that the user, SYSTEM, and administrators have Full Controller permission on their folders and all sub-folder under the roaming profile folder has inherited proper permission.

 

-      Check the share permission to ensure that Everyone has Full Control permission.

 
Please pay attention to the Event logs in Windows Logs--->Application. User Profile Service will log events to show the reason why the roaming profile is not applied.


http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_Server_2008/Q_24570842.html


take a look at this article looks pretty good:
http://www.windowsnetworking.com/articles_tutorials/Profile-Folder-Redirection-Windows-Server-2003.html
0
 
rsoly777Commented:
the best way to do this would be through Active Directory Group Policy. Another way you could do it is through their individual user account information on the profile path tab
0
 
martinmcginleyAuthor Commented:
How is this done in the group policy?  
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

 
rsoly777Commented:
0
 
martinmcginleyAuthor Commented:
I dont understand how you went from policy editor to folder redirerction.  I am looking for a simple solution.  With some detail on how to implement
0
 
rsoly777Commented:
You said you wanted to set their "default" Mydocuments folder to an area I have created on the server (D:\user_data). You can do this with Folder Re-direction in Group Policy or setting their user profile path in the user profiles to your location. Both have pretty much the same desired result. Most likely it would be easiest to do this in the user profile in ADUC console but you would need to input it separately for each user. Group Policy does this for all users in the Policy at the same time. Just a matter of how much typing you want to do.
0
 
martinmcginleyAuthor Commented:
I just tried changing the profile in AD and logged in with remote desktop.  It created the account on c:\users\name\my documetns.  

I guess it it the default profile location I am trying to change.  How do you do this?
0
 
martinmcginleyAuthor Commented:
thanks
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.