Solved

Exchange 2010 SP1 OWA premium not working

Posted on 2011-03-25
13
2,834 Views
Last Modified: 2012-08-14
After rollup 2 for OWA on Exchange 2010 SP1 OWA stopped working alltogether.  We got the basic client to work(kinda) after setting the default language, right now there are two issues.
1)  premium client doesn't work
2) basic client can't open any attachment or follow a URL w/in an email, trying to open an attachment or click on a link within the email pops up another window that displays the current basic client
 
We have had an incident open with Microsoft for nearly two weeks and no solution.
0
Comment
Question by:SOPHSupport
  • 7
  • 5
13 Comments
 
LVL 18

Expert Comment

by:Netflo
ID: 35219186
Hi SOPHSupport,

Can you please try the following from an elevated EMS:

cd "C:\Program Files\Microsoft\Exchange Server\V14\Bin\"
UpdateCas.ps1

Please copy the output and paste here. Test OWA premium connectivity and attachment options too.

Let me know how you get on.
0
 

Author Comment

by:SOPHSupport
ID: 35219665
The output from running the updateCas.ps1 script is at the bottom.  Results for OWA follow
I can login to premium client and get to the inbox,
1) In IE 8 clicking on email won't open it, I get "your network connection is unavailable" however using the reading pane <actions> I can open the email and reply. After opening the email via the reading pane I can open the email directly from the inbox- not all email just the ones I opened via reading pane-actions.
2) In IE 8 and Firefox options doesn't work
3) In FireFox some messages will open directly some won't
4) In FireFox sometimes attachements open mostly I get the error "There was a problem opening your mailbox.  You may have already signed in to Outlook We App on a different browser tab.  If so, clos this tab and return to the other tab.  If that doesn't work, you can try: closing your browser/deleting cookies"

Basic OWA works the same as it did.  Try to open attachment reopens the OWA inbox.

Output of UpdateCas follows
_________________________________________________________________
[PS] C:\Program Files\Microsoft\Exchange Server\V14\Bin>Version 14.1.270.1
[PS] C:\Program Files\Microsoft\Exchange Server\V14\Bin>[16:51:01] Copying files from 'C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\owa\Current' to 'C:\Program\Files\Microsoft\Exchange Server\V14\Bin>Files\Microsoft\Exchange Server\V14\ClientAccess\owa\14.1.270.1'
 [16:51:07] Found 1 OWA virtual directories.
 [16:51:07] Updating OWA virtual directories
 [16:51:08] Processing virtual directory with metabase path 'IIS://PHEALTH-CAS.sophad.local/W3SVC/1/ROOT/owa'.
 [16:51:08] Metabase entry 'IIS://PHEALTH-CAS.sophad.local/W3SVC/1/ROOT/owa/14.1.270.1' exists. Removing it.
 [16:51:08] Creating metabase entry IIS://PHEALTH-CAS.sophad.local/W3SVC/1/ROOT/owa/14.1.270.1.
 [16:51:08] Configuring metabase entry 'IIS://PHEALTH-CAS.sophad.local/W3SVC/1/ROOT/owa/14.1.270.1'.
 [16:51:08] Saving changes to 'IIS://PHEALTH-CAS.sophad.local/W3SVC/1/ROOT/owa/14.1.270.1'
 [16:51:08] Saving changes to 'IIS://PHEALTH-CAS.sophad.local/W3SVC/1/ROOT/owa'
 [16:51:08] Update OWA done.
 [16:51:08] Updating ECP to version 14.1.270.1
 [16:51:08] Copying files from 'C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\ecp\Current' to 'C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\ecp\14.1.270.1'
 [16:51:08] Update ECP done.
 [PS] C:\Program Files\Microsoft\Exchange Server\V14\Bin>
0
 
LVL 18

Expert Comment

by:Netflo
ID: 35219728
Is it possible to ask Microsoft Support to provide you with a summary of what has been done so far in terms of troubleshooting and to paste it here. Please ask them to be as detailed as possible.
0
 

Author Comment

by:SOPHSupport
ID: 35219879
I wish I could ask them, been waiting for them to get back to me for about 1 week.  What they did
rebuilt owa, checked directory permissions and examined quite a few things.  On my own I came across the following in a blog and it solved an initial problem where OWA was pretty much dead, but it left us where we are now.

set-OwaVirtualDirectory "owa (default web site)" -DefaultClientLanguage 1033
0
 
LVL 18

Expert Comment

by:Netflo
ID: 35219936
Have you emailed the support reps manager(s), if keep the pressure on explaining that most of your organisation cannot use webmail or mobile functionality, they should come back to you.
0
 

Author Comment

by:SOPHSupport
ID: 35220114
My institution is a Premier customer for what thats worth.  Complained to our rep several times, he promises but not much happens.  I don't call on M$ very often, probably been over 4 years since last call, but in the past they provided the best support I had ever experienced.  
In any event I got to looking at the problem and some of it seems to be related to the redir.aspx since the functions that don't work appear to use this executable.  Looking at the output of the UpdateCas I noticed IIS refers to the machine by the private dns which is different then the public.
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 
LVL 18

Expert Comment

by:Netflo
ID: 35220273
The private DNS referred to by IIS is normal, that command is to copy across any files that may have been corrupted. I would keep the pressure on, I've had a situation like that before where at 3am, I sent an email to all MS reps in the chain of emails demanding that Microsoft get back to me. I got a response 10 mins later from a senior manager explaining that he will get an engineer to the issue resolved, 2 hours later all sorted. I made the call as a MS Partner, never the less in my case the Exchange server in question could not receive emails. You just have to explain that you're getting pressure from management that this is affecting more than 50% of the business.

Could you tell me are you running Exchange on 2008 or 2008 R2? Do you have a self signed cert or proper 3rd party?
0
 

Author Comment

by:SOPHSupport
ID: 35220572
2008R2 proper signed cert from 3rd party
0
 

Author Comment

by:SOPHSupport
ID: 35222792
Found the problem(s)
Using IIS managment tool, drill down to the exchange site, in the redirect property make sure to uncheck 'redirect all to ...'   This solves the inability to open URLs w/in messages, download attachments and a few others.  

I haven't completed this yet but expect it to work, set default language to 0, this should enable options, change password, set automatic replies.  This should likely correct the problems with the view functions as well.

Summary:
There is a site that lists what the redirect properties should be, from the default site down, and it comes with pictures!  As soon as I can find where I put the link I will update this post.

There is another link that discusses setting the default language to 0 as a fix for the remaing unsolved symptoms.  I will update this post with the cmdlt syntax as soon as I verify it works.

Very disappointed with Microsoft support, this should have been a 30minute fix.
0
 
LVL 18

Expert Comment

by:Netflo
ID: 35222910
Great to hear, if could you provide the website link you found your solutions from.
0
 

Accepted Solution

by:
SOPHSupport earned 0 total points
ID: 35262340
Finally got Microsoft to respond and the problem solved.  From looking at the number of web pages that discuss this problem it appears that it is fairly common and there are many purported solutions that do provide some 'relief', i.e. changing the settings for redirect within the IIS managment tool.  
However, at least in our situation, the real problem is the webconfig file in the C:\program files\Microsoft\Exchange Server\V14\ClientAccess\OWA folder.  As I mentioned earlier changing the redirect settings for the exchange directory 'fixed' most of the OWA problems users in our 2010 Exchange were experiencing but for our legacy 2003 users it no longer allowed them to use servername\exchange as the URL to open the 2003 OWA.  The solution that resolved all issues was in the aforementioned web.config file,  there was a second system.webserver at the end of the file that shouldn't be there (I placed this section at the end of this missive), and according to the MS rep the GUI for managing IIS settings is unreliable so to eliminate any issues raised by our use of the GUI we went through the command line to set all of the sites redirect settings.  Oh joy.

web.config stanza that we removed follows
 <system.webServer>
        <httpRedirect enabled="false" destination="https://phealth.soph.uab.edu/owa" childOnly="true" />
        <tracing>
            <traceFailedRequests>
                <add path="*">
                    <traceAreas>
                        <add provider="ASP" verbosity="Verbose" />
                        <add provider="ASPNET" areas="Infrastructure,Module,Page,AppServices" verbosity="Verbose" />
                        <add provider="ISAPI Extension" verbosity="Verbose" />
                        <add provider="WWW Server" areas="Authentication,Security,Filter,StaticFile,CGI,Compression,Cache,RequestNotifications,Module,FastCGI" verbosity="Verbose" />
                    </traceAreas>
                    <failureDefinitions statusCodes="403" />
                </add>
            </traceFailedRequests>
        </tracing>
        <httpErrors errorMode="Custom">
            <error statusCode="403" subStatusCode="4" path="https://phealth.soph.uab.edu/owa" responseMode="Redirect" />
        </httpErrors>
    </system.webServer>
0
 

Author Closing Comment

by:SOPHSupport
ID: 35312627
<Rant>
Really disappointed with MS support (not individuals at Experts Exchange).  It shoudn't require 2 weeks and getting angry to have a case escalated.  In the past if the 1st rep couldn't solve the problem in an hour he would escalate it, if 2nd rep couldn't solve he would ...   I can recall having developers step in without my having to ask.  I appreciate the problem being solved but it took too long and I had to call repeatedly and complain.  Given the web.config file was not changed by me or my staff this seems certain to be an issue in MS upgrade QA.  
</Rant>
0
 

Expert Comment

by:ALAA_ELMAHDY
ID: 35472739
ok guys any one of you can give us a steps for solution or the command line which fixes the redirection issue.
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

"Migrate" an SMTP relay receive connector to a new server using info from an old server.
Easy CSR creation in Exchange 2007,2010 and 2013
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now