Solved

Remote desktop of windows 2008 server

Posted on 2011-03-25
8
648 Views
Last Modified: 2012-05-11
I like to take the remote desktop of the server located at my office from home.
The server is behind the router.

 I cannot use software like teamviewer which uses sessions.

I am providing the network diagram please guide me how to do.
 network
0
Comment
Question by:bitla
  • 4
  • 3
8 Comments
 
LVL 17

Expert Comment

by:OriNetworks
ID: 35219501
Configure the router to forward rdp packets on port 3389 to the servers ip address
0
 
LVL 11

Accepted Solution

by:
Patmac951 earned 500 total points
ID: 35219576
Agree with OriNetworks post....you need to allow and port forward inbound TCP traffic on port 3389.

If this was my network and just to add an extra layer of security I would change the default RDP port on the server to port other than 3389.  You can accomplish this by modifying the registry with the Regedit command.

Navigate to:


HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\Winstations\RDP-TCP

Scroll down to the Portnumber value and change the hexidecimal value for 3389 to something else.  I like to use a high number like 9894.   The server will require a reboot for this port value change to take effect.  If you do go this route you will have to modify your router config to allow inbound traffic and port forwarding for the port number you defined in the registry.  

Then your RDP connection would look something like this.   WAN IP address of the router:9894

If your WAN IP was 66.33.84.56 then your RDP connection would be 66..33.84.56:9894
0
 
LVL 11

Expert Comment

by:Patmac951
ID: 35219602
This might be implied but you want to make sure in the ROUTER when you set up your port forwarding that you NAT the WAN traffic coming from the Internet to the local LAN IP address of the server.  This way all inbound traffic coming from the WAN on that port is forwarded to the server IP address.
0
 
LVL 4

Author Comment

by:bitla
ID: 35226672
Ok I made a mistake in specifying as a router but its actually modem + Adsl2 router.
I went into the configuration page, click on NAT- virtual server and created a rule with local ip address which is 192.168.1.18 and port number 3389.

And also firewall is also disable in router configuration.

Enabled RPD on server,  Activated Allow incoming connections (Private and Public) in firewall settings.
Added Remote desktop user who are AD users.

In registry port 3389 was there with value 0x00003d.
I dont what 3d stands for.

Local Domain users can connect take the remote desktop.

Do i need to do anything else.

I like to explain from the start how the connection is.
==============================================
Server (supermicro) Xenon processor. with two Ethernet ports.
From the Modem (+router) one connection goes to Switch (24 port)--- from here connection goes to Server , clients and another wireless router (using ip address 10.x.x.x).
From this wireless router more 4 pcs and two laptops are connected.

I had an issue where clients where able to connect to domain but not access the Internet, so i used up the another Ethernet port on the server and connected to the same switch.

First Ethernet adapter(network Connection) has Static Ip address 192.168.1.100 and second Network connection on server has dynamic ip address. Now the Clients can connect to internet.

===============================
Then I try to take the RDP of server there is the issue.

Any help.

Regards
Bitla


0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 4

Author Comment

by:bitla
ID: 35237876
Can someone help me resolve the issue.
0
 
LVL 11

Expert Comment

by:Patmac951
ID: 35260123
Sorry for the delay in response.  If your local network users are able to access the RDP connection then the problem is within your ADSL router configuration.  If you have the firewall turned off within the router then the Asdl Router should be forwarding all packets.

I am little confused....you say the NAT in the router is set to 192.168.1.18 but the first ethernet adapter on the server is set to 192.168.1.100.  On the server if you go to a command prompt and run: c:>ipconfig /all what is the server IP address?

WHen you access the RDP connection locally within your network are you using the server name or the IP address in the RDP connection?

It sounds like your inbound NAT rule in the router may be set for the wrong IP internal address.
0
 
LVL 4

Author Comment

by:bitla
ID: 35275902
Patmac951 First thank you for reply.

There are two routers in the network (look at the image), one router (firewall turned Off) with ip address 192.168.1.1/24 with wan connected to it. and another router(10.x.x.x) is connected to switch which is inturn connected to first router.

The second router is not connected to server.

Sever machine has two network adapters with ip address 192.168.1.18 (dynamic) and 192.168.1.100 (static).

Router Configuration

http://www.shivaranjan.com/2006/07/11/portforwarding-airtel-220bx-router/

0
 
LVL 4

Author Closing Comment

by:bitla
ID: 35334662
I dont why i was able to take the remote desktop only after changing the port number in registry and router from default 3389.

But still unable to access using wan ip address with pc in lan.
ie for example 192.168.x.x trying to RDP 122.x.x.x: 5555

error unable to connect.

from wan 183.125.x.x i am able to connect to 122.x.x.x.:5555

any suggestion would be appreciated
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

The recent Microsoft changes on update philosophy for Windows pre-10 and their impact on existing WSUS implementations.
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
This tutorial will show how to configure a new Backup Exec 2012 server and move an existing database to that server with the use of the BEUtility. Install Backup Exec 2012 on the new server and apply all of the latest hotfixes and service packs. The…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now