Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Changing Autodiscover HTTP redirect URL

Posted on 2011-03-25
17
Medium Priority
?
4,432 Views
Last Modified: 2012-06-27
When i originaly installed CAS 2010 in my exchange 2003 organization i used hostname"cas.domain.com/.." for external URLs.  We then decided to change hostname to mail.domain.com.  So i set the external url on all virtual directories including the 'autodiscover' to the new hostname using EMS.  When i run remote connectiveity analyzer, i see that in the step where it tests the HTTP redirect it still goes to the old url.  I checked all virtual directories,  i used -Getxxx : fl *  to view each directory and all of them showed the new external url "mail.domain.com".  I also check them in IIS.  They are all using the new host name.  Also, users (still on exchange 2003) get the the popup to allow redirect to to 'cas.domain.com/..." which is the old host name.   I have the redirect url set to use the new name.  The SAN certificate has the new name.  AD objects attributes show the new name.  But something is still referening the old the name.  Here is the error in ExRCA.
---------------------------------------------------------------------------------
ExRCA is checking the host autodiscover.domain.com for an HTTP redirect to the Autodiscover service.
  The redirect (HTTP 301/302) response was received successfully.
   Additional Details
  Redirect URL: https://cas.domain.com/Autodiscover/Autodiscover.xml 
 
 Attempting to test potential Autodiscover URL https://cas.domain.com/Autodiscover/Autodiscover.xml 
  Testing of this potential Autodiscover URL failed.
-----------------------------------------------------------------------

What is it that i'm missing here?  Why is it still redirecting to the old URL?  I also have to mention that i actualy removed and recreated all virtual directories (OWA, EWA,..) and it sitll tries to redirect to old url.   Any help on this will be greatly appreciated.
0
Comment
Question by:Zeetan
17 Comments
 
LVL 8

Expert Comment

by:praveenkumare_sp
ID: 35220401
does the exchange 2010 users work fine ?

exchange 2003 does not have autodiscover to work

what is the primary smtp address of the users in exchange 2003 ?

what email address they used to create the outlook account ?


answering these questions will help not only me even u to understand where the issue is
0
 

Author Comment

by:Zeetan
ID: 35220454
There are no exchange 2010 users.  Everyone is still on 2003.   The issue is that the old external url (cas.domain.com) is still being used.   I know that because i see it in ExRCA results and more importantly when the users get the popup to allow redirect to the old url.   I need to know where could that URL be refereced?   given the the fact that i have viewed alll setting as explained in my previous port and they all showed the new URL.
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35222769
Get-clientaccessserver | fl name,*uri*

It shld return CAS.domain.com in your case,

Change it by running set-clientaccessserver
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 

Author Comment

by:Zeetan
ID: 35224218
Hi Akhater,   when i run "Get-clientaccessserver | fl name,*uri* it only shows the locat internal hostname of the server which is (servername).    I think the main issue for me is that the autodiscover service redirect URL when it tries to use HTTP is referecing the old external URL (cas.domain.com). See below..

---------------------------------------------------------------------------------
ExRCA is checking the host autodiscover.domain.com for an HTTP redirect to the Autodiscover service.
  The redirect (HTTP 301/302) response was received successfully.
   Additional Details
  Redirect URL: https://cas.domain.com/Autodiscover/Autodiscover.xml
 
 Attempting to test potential Autodiscover URL https://cas.domain.com/Autodiscover/Autodiscover.xml 
  Testing of this potential Autodiscover URL failed.
-----------------------------------------------------------------------

How do i change the redirect to use the new URL  mail.domain.com?




 

0
 
LVL 49

Expert Comment

by:Akhater
ID: 35224227
ok let me ask you another question, do you have an srv records in your EXTERNAL dns zone _autodiscover pointing to cas.domain.com ?

if you don't know drop me your domain i will do the test for you (way to contact me in my profile)
0
 

Author Comment

by:Zeetan
ID: 35224584
No i don't have any srv records in my external zone pointing to cas.domain.com.  Both autodiscover.domain.com and mail.domain.com point to the public ip of the cas server.  
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35224955
It cant be exrca works like that

A. Check for domain.com/autodiscover it it fails
B. Check for autodiscover.domain.com if it fails
C. Chech for srv records

So,if you have an autodiscover A record it will use it!

Create for me a test user/ pass so i can help out
0
 

Author Comment

by:Zeetan
ID: 35227829
Thanks Akhater...I'd love to give you test user to help me resolve this but it may get me in trouble:)..im sure you understand.   Ok so below is a paste of the ExRCA test details for the part that is failing.  Thisi is the test where it attempts to contact the autodiscover service using the HTTP redirect method.  The problem is that the Redirect URL it uses is the old external name (cas.domain.com).  It will then of course tries to resolve the old name and checks for srv record but it can't find it because it no longer exists.  All other test are succesful and show the new external name which is (mail.domain.com).   Below is the failing test and  I have bolded the part in question.    

-----------------------------------------------------------------------------------------------------------------
Attempting to contact the Autodiscover service using the HTTP redirect method.
  The attempt to contact Autodiscover using the HTTP Redirect method failed.
   Test Steps
   Attempting to resolve the host name autodiscover.domain.com in DNS.
  The host name resolved successfully.
 
 
 Testing TCP port 80 on host autodiscover.domain.com to ensure it's listening and open.
  The port was opened successfully.
ExRCA is checking the host autodiscover.domain.com for an HTTP redirect to the Autodiscover service.
  The redirect (HTTP 301/302) response was received successfully.
   Additional Details
  Redirect URL:https://cas.domain.com/Autodiscover/Autodiscover.xml
Attempting to test potential Autodiscover URL https://cas.domain.com/Autodiscover/Autodiscover.xml 
  Testing of this potential Autodiscover URL failed.
------------------------------------------------------------------------------------------------------------------
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35227850
OH well that's it then :)

open your IIS find your autodiscover virutal direcotry you have a redirection option on your right hand side check it ;)
0
 

Author Comment

by:Zeetan
ID: 35228747
This was the first thing i checked when i first had this issue.  The redirection on the autodiscover virutal directory show the correct address: mail.domain.com.  Strange!! I know.   Where else could that setting be stored?
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35231893
any ISA/TMG servers ?
0
 

Author Comment

by:Zeetan
ID: 35236918
Nope, no ISA.  The CAS is behind a load balancer which configured to send requests to "mail.domain.com" and "autodiscover.domain.com (443, 80, etc..) to the CAS server.  I checked with the network folks previously and they said that they don't have anything configured for cas.domain.com
0
 
LVL 49

Expert Comment

by:Akhater
ID: 35236985
there is one last thing that it could be

open iis go to your autodiscover virtual directory and click Explore

any file there like default.html .asp something ?

can u share a screenshot of this directory
0
 

Author Comment

by:Zeetan
ID: 35243760
I explored the autodiscover virtual directory and didn't see anything.  I even opend each files and searched for the old name and didn't get any resutls.   Here is a screenshot
autodiscover.bmp
0
 

Expert Comment

by:mbrooks27
ID: 35475636
http://support.microsoft.com/kb/940726 should help and resolve the issue.
0
 

Accepted Solution

by:
Zeetan earned 0 total points
ID: 36367105
Only reinstalling the CAS got rid of the old name.  
0
 

Author Closing Comment

by:Zeetan
ID: 36394990
Only reinstalling the CAS got rid of the old name but im sure there is a better way to do it.
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You finally migrated Public Folders to Office 365, decommissioned the Public Folder mailbox database and since then, when you send an email from on-premise to mail-enabled Public Folders, you get the following error: "Misconfigured public folder mai…
In this post, we will learn to set up the Group Naming policy and will see how it is going to impact the Display Name and the Email addresses of the Group.
In this video we show how to create an Accepted Domain in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Ac…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Suggested Courses

564 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question