Defrag Exchange 2003 - Eseutil Jet error -1811

Hi,

I am getting the following error when I try to kick off an offline defrag usuing eseutil

***************************************************************************************************
C:\Program Files\Exchsrvr\bin>eseutil /d "C:\Program Files\Exchsrvr\Exchsrvr\M
DATA\priv1.edb" /t e:temp.edb

Microsoft(R) Exchange Server Database Utilities
Version 6.5
Copyright (C) Microsoft Corporation. All Rights Reserved.

Error: Access to source database 'C:\Program Files\Exchsrvr\Exchsrvr\MDBDATA\p
v1.edb' failed with Jet error -1811.

Operation terminated with error -1811 (JET_errFileNotFound, File not found) af
r 0.32 seconds.
****************************************************************************************************

the steps I have completed so far are:
1. Dismounted the Info Store
2. Connected an external hard drive to the server with enough space to run the defrag
3. I ran the defrag a couple of nights ago but had to stop the defrag as it took too long so I re-scheduled it for the weekend
4. It created two temp.edb and temp.stm files on the external hard drive - I deleted theses files today before I kicked of the defrag
5. When I kicked off the defrag I get the above error.
6. I have tried stopped all the exchange services and re-running the defrag but no joy

Any ideas?

Would this occur due to the fact I deleted the two temp.edb files from my initial running of the defrag where deleted?
ANScrewAsked:
Who is Participating?
 
Alan HardistyCo-OwnerCommented:
Make sure the Information Store Service is started also (as you mentioned you had stopped all the Exchange services).
0
 
ajwukTechnical Consultant / Project ManagerCommented:
It's most likely because you killed an offline defrag previously. ESEUtil is a very powerful tool and can cause a lot of damage to your Exchange database if used incorrectly.

How much space are you hoping to reclaim? What does the online defrag report in event viewer?

Are you currently able to mount the Exchange database?

I would run eseutil /k to check the integrity of your Exchange database first.
0
 
ajwukTechnical Consultant / Project ManagerCommented:
0
 
Alan HardistyCo-OwnerCommented:
Your path is wrong!

Please use the following command:

C:\Program Files\Exchsrvr\bin>eseutil /d "C:\Program Files\Exchsrvr\MDATA\priv1.edb" /t e:temp.edb

You had the exchsrvr path twice, which I very much doubt is correct and the error you are getting is "I cannot find the file".
0
 
ANScrewAuthor Commented:
Thank you Alan - that worked - silly typo in the end ;)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.