Need help installing Nvidia Geforce 210 driver Ubuntu

Hello all,
I have a Dell Dimension E521 running Windows XP and Ubuntu 10.10. I purchased a video card called Nvidia Geforce 210 and installed it.
I am connecting this to a Sony Bravia LCD tv via HDMI.
I installed the driver for Windows xp and everything works just fine. When I boot into Ubuntu, I installed the driver through "Additional Drivers" as
recommended by Nvidia. I have good quality video with compiz running just fine. The only problem is... theres no sound. I am running a 2.6.35 kernel.
I disabled the onboard sound card. I have attached a few screen shots when I run "aplay -l" and "sudo alsamixer" I believe I need to tell alsa to use the HDMI
card for sound, but I have no idea how to do that. Can someone please provide me a simple step by step how to.

Thank you so much in advance!
LVL 3
schwabdaleAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

schwabdaleAuthor Commented:
0
nociSoftware EngineerCommented:
Well alsa just creates all devices.
and mostly the first device is taken by an upper layer (gnome/kde/...) config to be the default sound device.
Unless configured differently.  (see tools like phonon, pulseaudio, gstreamer.)


0
Duncan RoeSoftware DeveloperCommented:
When you use F6 to select sound card, what choices are you offered? It does look as if you are already using the right one.
F5 may show you more sliders. I'm a little surprised there is no entry for "Master"
0
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

schwabdaleAuthor Commented:
Here's a screenshot of "F6". Nvidia Support told me this,
Quote:
Since you are using Ubuntu 10.10, you will need to disable the open source nouveau driver since it is included in Ubuntu 10.10. The instructions to disable nouveau are at this link in section 8.1: http://us.download.nvidia.com/XFree86/Linux-x86_64/260.19.44/README/commonproblems.html

Then they told me this,
Quote:
It is actually easier to install the NVIDIA driver the way you originally tried so please do that again (System -> Administration -> Hardware Drivers)

Then please refer to this document ftp://download.nvidia.com/XFree86/gpu-hdmi-audio-document/gpu-hdmi-audio.html which provides the information you need to setup HDMI sound, and let me know if any questions.



I thought I may just need to stop the X server, then install the driver, then start X again. However, when I tried to do this I could not get X going again.
0
schwabdaleAuthor Commented:
Sorry, heres the screenshot of "F6"
SoundOptions.png
0
Duncan RoeSoftware DeveloperCommented:
Getting X going again: have a look at /etc/X11/xorg.conf. Likely you'll find it specifies the nouveau driver. You need to change that to nvidia.
<rant>Personally I would never buy another Nvidia card whilst ever they have a closed-source driver. Nouveau is a great effort but they get no help from Nvidia. I ditched my last Nvidia card for an ATI Radeon - at least the open-source driver can give me the resolution I want.</rant>
As regards F6 - I would try selecting choice 1. If that doesn't help, select choice 0 (but I suspect that would be the default).
Master looks good.
If problems persist with starting Xorg, post /var/log/Xorg.0.log, preferably as a file attachment (It's usually quite long).
You might want to look at it first, in case you can spot the problem yourself ;)
0
schwabdaleAuthor Commented:
When I select any of the choices I get the same result..no sound. As for the video card I have now (nvidia), I only have a few days
before I can return the card for a refund, or exchange it. Would anyone have any recommendations for a card for a Dell Dimension
E521 (Needs to be HDMI and 1024mb)? Its a PCIe x16 card. I will be getting it from http://www.microcenter.com/search/search_results.phtml?N=4294966938

I will try to post the Xorg.0.log file later on today. However, if I can't get it to work quickly, I may just exchange it for a ATI card.
Seems like I may have better (out of the box) luck with ATI using HDMI. Agree?

Please recommend a card from this site under $60.00 in the event I need to return it.

Thanks
0
schwabdaleAuthor Commented:
0
Duncan RoeSoftware DeveloperCommented:
The Diamond 6850PE51G ATi Radeon HD 6850 1024MB GDDR5 PCIe 2.1 x16 Video Card looks pretty good to me - bit more than I'm used to paying ($50) but it does have HDMI. And it's an ATI Radeon, so the open source driver should be fine (although personally I've never used sound in conjunction with a video card). I did get a Sparkle card for my elder son once, but he ridiculed it.
The Diamond Radeon HD 5450 512MB DDR2 PCIe 2.1 x16 Video Card is more in my price range at $49.99 and also has HDMI. I guess that's the one I would buy.
Just my opinion.
Cheers ... Duncan.
0
Duncan RoeSoftware DeveloperCommented:
Actually, crawling under my desk and around the back of my (rather heavy) full tower PC, I see a patch of dust in the back of my video card which could well be an HDMI socket. lspci reports:
01:00.0 VGA compatible controller: ATI Technologies Inc RV710 [Radeon HD 4350]
0
nociSoftware EngineerCommented:
You can influence the order of alsa devices by including an index=n n=0,1...  on the snd-... modules in /etc/modules.conf or related files.
The card you show in your first screenshot seems to be the right one.
The 2nd screen shot shows a different card (see the chip name  HDMI/DP vs. Sigmatel..)

So forcing the HDMI to be alsa device 0 will probably help.
0
schwabdaleAuthor Commented:
Thanks for the recommendations.
If I force it to be device "0"..how will that put sound out through HDMI?
0
nociSoftware EngineerCommented:
Because upper layers use device 0 as unless otherwise specified. the other way is to find out how upper layer sound is configured and select the right device every where.
By selecting the HDMI to be device 0 you effectively do the same.
0
schwabdaleAuthor Commented:
I see. Can you please provide me a step by step on how to do that?
0
nociSoftware EngineerCommented:
I don't have ubuntu.. But I did have similar problems with an USB-Phone being detected first and all sound going there...
(in my case usb preceded the hda_intel driver your problem is it's only one driver with multiple devices...)

snd_hda_intel  is the main driver
and it loads various codecs for you  (That needs to be adjusting using a probe mask).

So the goal is to load the hda_intel driver on first spot and the codec for HDMI as device 0.
It will need fiddling with probe masks on the snd_hda_intel driver .



First you need to find out the device number with:
aplay -l
What does aplay -l show you now in the current setup. (select the device with the HDMI in the name).

This:
egrep -l "options[ \t]+snd_hda_intel" /etc/* /etc/*/* /etc/*/*/*

gives you a file name that contains the spec for the sound device

there look for line containing:
options snd_hda_intel .....
If it isn't there another aproach is needed.

add order=0 probemask=n

n = 1 if only  device  1 should be probed, or 5 (101) or device 1 & 3 need to be probed.

and setup the correct bit depending on the device number:
device  Probe
nr         mask
0          1
1          2
2          4
3          8

I can add info when you reply with more on the above devices.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
schwabdaleAuthor Commented:
Thanks for your comments. I ended up running out of time. I had to return the card. However I did get stuck when you said "If it isn't there another aproach is needed" but didn't have time to get back to you. I think you would have solved the problem though. Based on the other ATI suggestion, I purchased a ATI card and it worked out of the box. Thanks All!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux OS Dev

From novice to tech pro — start learning today.