Unable to move WSUS 3.0 database due to insufficient permissions to drop connections

I need to move the wsus database from one drive to another.

I understand the instructions given at the three sources given below. My problem is that when I try to execute the "detach database" from within Studio, I get the message "The user does not have permission to perform this action. (Microsoft SQL Server, Error: 297")

I am connected to studio as the same administrative user that did the install of SBS 2008. I understand that this should be a simple manual change to permissions but I want to do it correctly and I'm not sure what permissions are needed or if I ought to connect differently.


http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_26219998.html?sfQueryTermInfo=1+10+30+databas+move+wsu

http://blog.augustoalvarez.com.ar/2009/01/25/wsus-30-connecting-managing-and-moving-susdb-as-internal-database/

http://blogs.technet.com/b/sbs/archive/2009/09/23/how-to-move-wsus-content-and-database-files-to-a-different-partition.aspx

kflorianAsked:
Who is Participating?
 
kflorianAuthor Commented:
The answer which worked for me was to completely uninstall WSUS and reinstall to the new location.
0
 
Jeffrey Kane - TechSoEasyPrincipal ConsultantCommented:
You don't move it from SQL Management Studio.  Instead you need to use the SBS Management Console just as described in http://e-e.com/Q_26219998.html

Jeff
TechSoEasy
0
 
kflorianAuthor Commented:
I used the Wizard before posting my question.

The Wizard moved to the new location  ..\WsusContent which is fully populated as expected.

In the new location it created a folder ..\SUSDB\UpdateServicesDbfiles  which is empty.

In the original location exists ..\wsus\UpdateServicesDBFiles which contains SUSDB.mdf and SUSDB_log.ldf.

0
 
kflorianAuthor Commented:
I tried the variou solutions offered by experts. My trial-by-error solution was the one that worked for me.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.