BSOD WIndow 7 64bit Toshiba LT model Satellite a505-s6960

Clean scan from MWbytes.org Free Antimalware.
Clean scan results from Spybot S&D
Clean scan from MS Security Essentials.
Memory test pass.
Toshiba PC- Diagnotics tool passed tests.
CHKDSK found issues and fixed, still get Blue Screen after scan
Safe mode is more stable than Normal but I have witness a single shutdown from SafeMode.
System freezes in Normal mode as well as Blue Screens. See attached files for dmp data.
I saw a bios update avail at toshiba 1.8 current =1.5 wasn't sure if I should apply it.
LIke to hear from someone that can read the dmp file
Thanks to all for your assistance. Its highly appreciated.

032611-23852-01.dmp WER-980325-0.sysdata.xml
jefflittfinAsked:
Who is Participating?
 
ded9Connect With a Mentor Commented:
Able to debug the dump files.

BSOD is caused due to ataport.SYS

Cause:- Could be a failing hard drive, two devices using the same irq, or the cable to Hdd is bad.

Resolution: Replcae the cables to hdd, try connecting hdd to another channel, Replace the hard drive.

http://msdn.microsoft.com/en-us/library/ff551332.aspx




Ded9
0
 
JohnBusiness Consultant (Owner)Commented:
Before you do a BIOS update, I suggest your Wndows 7 has been badly corrupted. I suggest now, that you back up your system (to be sure) and then do an in place Windows 7 repair. Here is the Microsoft support article to do that:

http://windows.microsoft.com/en-CA/windows7/products/features/startup-repair

... Thinkpads_User
0
 
jefflittfinAuthor Commented:
Thanks for the suggestion. Is that based on the content of the dmp file or a general suggestion?
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
RaneeshIT SupportCommented:
CHKDSK found issues and fixed, still get Blue Screen after scan; did you check this later? have you found any errors?
0
 
JohnBusiness Consultant (Owner)Commented:
Some of these errors can be caused by a damaged OS as well as hardware. If you think the hard drive is bad, by all means replace it. If you are not sure, the suggestion above to do an in-place repair is a general approach to use when hardware is good. ... Thinkpads_User
0
 
JohnBusiness Consultant (Owner)Commented:
In your first post, you said PC diagnostics passed. Did that include hard drive tests?  If so, your hard drive may be OK. You can always download the separate Hard Drive test program usually available on manufacturer's web sites and try that. ... Thinkpads_User
0
 
jefflittfinAuthor Commented:
Thanks for the tips. I did another CHKDSK and no errors were reported.
The hard drive test was part of the PC Diagnostics test and no error was reported.
Its a laptop so trying another hard drive cable is really not an option but I'll remove the drive and have a look.
I will run spinrite on the hard drive and see if finds any problems.
Thanks for looking into the dmp file to pin point the error.
I've backed it up so depending on what spinrite finds I may approach the OS in place repair if its an option.
 Its been running for 24 hours now without a freeze up or Blue screen, but as sure as I turn it over to the customer it will fail.
I'll post back with results of the hard drive check with spinrite.
Thanks again for all of the input.
0
 
ded9Commented:
Any luck?????

Ded9
0
 
nobusCommented:
the disk problems can be caused by disk - or by the disk controller (= mobo)
you can run spinrite, but i prefer HDD regenerator (it does about the same, but was able to fix disks for me that Spinrite could not) - it also works faster : http://www.dposoft.net/

you can install the OS on another disk to test if it is the disk, or controller
0
 
jefflittfinAuthor Commented:
Spinrite ran for 24hrs and only digested 1% and appeared to be hung up on a bad cluster. So I terminated the program. I will try dposoft.
I will attempt another drive as well.
Thanks for the suggestions.
I'll post back the results of my findings.
If I install a new hard drive would you suggest cloning the drive to preserve data and programs or would you suggest a fresh install of the OS and reload apps and data?
0
 
JohnBusiness Consultant (Owner)Commented:
>>> If I install a new hard drive would you suggest cloning the drive to preserve data and programs or would you suggest a fresh install

If your hard drive has a problem (looks like it), then there is a reasonable chance some OS damage was doen as well.

I would highly recommend a fresh install on a new hard drive.  ... Thinkpads_User
0
 
nobusCommented:
always first backup
you can copy your data to an usb drive, when running from a live Knoppix cd : ftp://ftp.kernel.org/pub/dist/knoppix/KNOPPIX_V6.4.4CD-2011-01-30-EN.iso 

i never clone a bad drive - for obvious reasons : you just copy the problems
0
 
jefflittfinAuthor Commented:
So I pulled out the hard drive and stuck it into another computer and MS Security Essentails found a virus in the MBR. Trojan:DOS/Alureon.A  
boot:\device\harddisk1\DR1
boot:\device\harddisk1\DR1\(MBR)
boot:\device\harddisk1\DR1\(MBR)\(MBR)
MS sec. ess. tried to repair it and requested the system be rebooted. This happened twice, second time it found the virus again and requested a reboot. 3rd time no errors
So I stuck the HD back into the laptop and now I can't get it to boot.
I can boot from Win 7 repair disk that I made before this problem and get to a command prompt.
I ran bootrec /fixboot and no joy
I ran bootrec /fixmbr - no joy.
I ran bootrec /rebuildbcd - still no joy.
Any suggestions to help boot the computer would be appreciated.
When I boot from the Win 7 repair disk. The C: is the recovery partion and the D: drive is where Windows is loaded.
I would love to just run the factory restore at this point but I can't boot it to get to that option.
0
 
jefflittfinAuthor Commented:
I should mention that I tried startup repair from the Win 7 repair disk to start with after I re-installed the HD. First time booting it just gave me a cursor in the upper left corner and nothing happend. So I inserted the Win 7 repair disk and tried the Start up repair option. When it rebooted I get the same thing which is a flashing cursor in the upper left corner.
It tells me that Windows 7 home preium is the OS found on the D: Shouldn't it be C: for the OS and D: for the recovery partition? Its like its switched.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.