uninstall Exchange 2010

Hello,

I need to uninstall Exchange 2010 (I can erase all data) so I can Install it again with a clean install
When I want to uninstall the SERVER MAILBOX ROLE it tell me that I cannot unistall since Database contain mailboxes. I want to erase everything. Any easy way to do it ?

Thank you
gadsadAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Glen KnightCommented:
This will be because of the arbitration mailboxes.

From the Exchange Management Shell run the following to get the names of the mailboxes:

Get-Mailbox -Database DATABASE_NAME - arbitration

Replace DATABASE_NAME  with the name of your database.

Then run:

Remove-Mailbox MAILBOX_NAME -Arbitration -RemoveLastArbitrationMailboxAllowed
0
praveenkumare_spCommented:
ya i have had the same issue

just want to add to the previous comment , just make sure u have all the required roles to do the same.

as when i was doing Remove-Mailbox MAILBOX_NAME -Arbitration -RemoveLastArbitrationMailboxAllowed was not working as i did not have the appropriate role
0
gadsadAuthor Commented:
I cannot execute these commands, I may not have the roles or the permission
Get-Mailbox -Database does not work
any solution ?
Thank you




 
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Glen KnightCommented:
Are you adding the name of the database?

0
gadsadAuthor Commented:
yes
get-mailbox -database "Mailbox Database 1722727489" -arbitration

and the command do not work
I tried everything, very strange
Could it be a right problems?

If I format the server should I be able to reinstall Exchange 2010 ?
0
AkhaterCommented:
What do you by the command doesn't work ? What is the error?


Try

Get-mailbox -arbitration | Remove-Mailbox -Arbitration -RemoveLastArbitrationMailboxAllowed
0
gadsadAuthor Commented:
Here the error

Get-mailbox -Arbitration
the object "-arbitration" cannot be found in 'SERVER1.DOMAIN.LOCAL'
(the issue is that SERVER1 is the AD/DC server, Exchange2010 sever is called EXCHANGE1 (member server), is it normal ?

Remove-Mailbox -Arbitration
"remove-mailbox" not a known command applet, function or executable program. Check syntax or path....

 
0
AkhaterCommented:
It is a permission issue what user are you using? Make sure it is member of echange organization management
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gadsadAuthor Commented:
Problem is solved
It was indeed a permission issue
Thank you very very much
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.