MSExchangeSyncAppPool (w3wp.exe) consuming all CPU time!

Hi

I have 2008 R2 server where I run Microsoft Exchange 2007. I noticed that the server was running very slow so I checked the task manager and I realised that one intance of w3wp.exe was taking all the resources. I tracked the instance to be related to the MSExchangeSyncAppPool. As soon as I stop that app pool the server goes back to "normal".

I've tried adjusting "Recycling" and other options in the same category but nothing helps.

Anyone?!
CaperuzzoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Alan HardistyCo-OwnerCommented:
Do you have any iPhones with iOS 4.0 on them?  Is so, this is a known problem and they need to have the iOS upgraded to the latest version.

My blog describes the issue:

http://alanhardisty.wordpress.com/2010/07/02/apple-ios4-issues-with-iphone-4-3gs-3g-and-exchange/

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CaperuzzoAuthor Commented:
Thank you. I will give this a try and get back to you!
CaperuzzoAuthor Commented:
Thank you alanhardisty! Worked perfectly!
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

eli_migdalCommented:
how can i see which accoutn is causing the problem ?
eli_migdalCommented:
I have the same excact problem ,
i have lots of Apple users , aprox 50 ...

how can i narrow it down and find the problematic one ?
gfsupportCommented:
This person has suggested Exmon to find out which user is causing the problem. I'm about to try that myself.

http://blogs.technet.com/b/mikelag/archive/2008/07/15/iphone-2-0-and-high-cpu-usage-on-exchange-servers.aspx

-Mike Sackur
eli_migdalCommented:
The new exchange rollup fixed it
eli_migdalCommented:
And the problem is back :(
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.