i got cgi-sys/defaultwebpage.cgi after i change the ip address of my domain

i have my own linux server and i have many sites on it
i have changed the ip address of some somains
www.7ammil.com
www.9or.cc
www.risemyweb.com

after i changed the ip address i have been redirected to something like
http://www.7ammil.com/cgi-sys/defaultwebpage.cgi

I have cleard the cahe in browser but i got the same page
please help me wit this

thanks
LVL 3
dr_lionheartAsked:
Who is Participating?
 
farzanjCommented:
I am sorry, I don't know what are we trying to troubleshoot.  In the light of what I saw, every thing worked fine.
0
 
farzanjCommented:
So if I enter URL
www.7ammil.com

Which page do you want it to go to?

Do you have "ScriptAlias" in your httpd.conf  (Apache configuration file)?  If so please show it to me.
Did you create any RewriteRule?  If so, please show it to me
0
 
dr_lionheartAuthor Commented:
i am not an expert with servers
every thing was working fine until i gave these domains a new dedicated ip from the whm panel

i noticed also that the domain is woking without www
http://7ammil.com

0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
dr_lionheartAuthor Commented:
every other page in the sites are working except the home page
working
http://www.7ammil.com/index.php/
this is redirecting
http://www.7ammil.com
0
 
farzanjCommented:
If I understand you correctly, this is how it is supposed to be working.

When you open a website, you are supposed to load an index file.  It works though the tag or option Indexes.  This option tells which page it is supposed to load when you go to the URL, which only tells the address of a default folder.  This default folder is written in the DocumentRoot.  Apache is supposed to look for an index file in your document root.  As I said these files are specified by the Indexes option.
0
 
dr_lionheartAuthor Commented:
and where can i find these indexes option
0
 
farzanjCommented:
It is in your Apache configuration file.  Try finding it through whm. Normally it looks for index.html, index.php, index.cgi, etc. files.  If it finds one of these files in the DocumentRoot folder, it loads it.
0
 
dr_lionheartAuthor Commented:
i went to the DirectoryIndex Priority
i found all the known indexes are specified
0
 
farzanjCommented:
Yes.  This is the way it is supposed to be.  As I said, to me everything appears working right as it should be.

I am sorry but I really don't understand what you are looking for.  All the behavior you told me is completely normal.  If I am missing something, please let me know.  If not, I think everything is great.
0
 
dr_lionheartAuthor Commented:
did you got the cgi-sys/defaultwebpage.cgi when you opened the sites??
0
 
farzanjCommented:
I entered http://www.7ammil.com/

And I got the same.

I did not get cgi-sys/defaultwebpage.cgi

If you want me to get that, you will need to create a ScriptAlias
0
 
dr_lionheartAuthor Commented:
if you did not get that
good
this is what i want
may it takes sometime after everything returns to normal
0
 
shaunakCommented:
Check the user privileges for the IP usage. The IP which you are assigning might be delegated / dedicated / shared with some one else.
0
 
dr_lionheartAuthor Commented:
how to check for that??
0
 
dr_lionheartAuthor Commented:
thanks the help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.