Cisco router interface questions

Hello guys, just a quick question - I plugged in an 1841 router FE 0/0 interface in to a 2821 router's HWIC-4ESW port, the config is as below:

On the 2821:
interface FastEthernet0/1/0
 switchport access vlan 65

interface Vlan65
 ip address

On the 1841:
interface FastEthernet0/0
  ip address

Both the routers the interface and protocols are up, signifying everything should be working.

Now I understand the 4ESW are switched ports - and that interface VLAN's don't necessary mean 802dot1q VLAN's - as in, I could get away with not specifying a VLAN on the other side, on the 1841 router.

But I cannot ping from one router to the other - anything I'm missing here :)

Appreciate the help.
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

John MeggersNetwork ArchitectCommented:
Did you "no shut" the interfaces?  When you do a "show interface fa0/1/0" what do you see?  It should show "up / up".
demon777Author Commented:
yea it shows up/up  - I have tried shut/no shut many times.
I've tried this scenario out with a Layer 3 switch - connected to a switchport L2 router (877) and it works perfectly. Just can't figure out why it won't work here!
What about speed/duplex or cable type (crossover/straight through). Do you see each devices mac address on their respective connected ports?
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

demon777Author Commented:
The fact that both the interfaces are up/up, 100Mbit and Full-duplex - I wouldn't think it would be a crossover that's needed? I do see mac addresses on the respective connected ports, not sure how this matters?

I was thinking more along the lines of - vlan's not being configured on the 1841 side, would this make a difference? What I've tried so far on the 1841:

interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
interface FastEthernet0/1.65
 description **Connect to Core 2**
 encapsulation dot1Q 65
 ip address


VPN-Hub2#sh vlans

Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/1

 This is configured as native Vlan for the following interface(s) :

   Protocols Configured:   Address:              Received:        Transmitted:
        Other                                           0                 172

   25 packets, 9875 bytes input
   172 packets, 11734 bytes output

Virtual LAN ID:  65 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/1.65

   Protocols Configured:   Address:              Received:        Transmitted:
           IP                     0                   0
        Other                                           0                   5

   0 packets, 0 bytes input
   5 packets, 230 bytes output

And still no go :( Tried configuring the 2821 with a switchport access trunk command as well to see if it carries any packets which are not tagged but no luck.
Marius GunnerudSenior Systems EngineerCommented:
do you have any other ip addresses configured on the routers?

try pinging using a source ip address of the vlan 65 connected interface.
demon777Author Commented:
I should have mentioned, have tried source pings and they do not work - there is no ACL's configured on the two routes as well!

The routers do have multiple interfaces.
Marius GunnerudSenior Systems EngineerCommented:
Routers do not handle/use vlans the same way switches do.

could you do a show interface fa0/1/0 on the 2821 and do the same on interface fa0/1 on the 1841. Check to see what encapsulation is being used.  I suspect that ISL is being used on the 2821 and dot1q is hardcoded into 1841.

If this is not the case. Remove the interfaces from the vlans and configure the IP address on the main interface and ping to make sure that the connection is working and nothing wrong with the cable.
demon777Author Commented:
@MAG03 that was my first concern. But I have confirmed it is dot1q on both ends (which is why I used subinterfaces on the 1841)

Core-Router-2#sh int fastEthernet 0/1/0 switchport
Name: Fa0/1/0
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Disabled
Access Mode VLAN: 65 (VLAN0065)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 10
Protected: false
Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

There's no spare FE ports available on the 2821 unfortunately - it is a production environment. I have also tested different cables.
 I will be taking a spare 4ESW and plugging it in the 1841 soon, I can't really figure out why this isn't working!
Marius GunnerudSenior Systems EngineerCommented:
is spanning-tree running ?
demon777Author Commented:
All ports are in forwarding state MAG03.

We since tried a 4ESW in the 1841 and it seems to have worked - I'm not sure what the real problem was (there was an overlapping IP but in a different part of the network - something that shouldn't affect this connection), but i'll keep this question open and report back soon.
demon777Author Commented:
Update - I had tried this :

2821 Fastethernet --- 1841 Router A Fastethernet; and then
Router A 1841 4esw --- Different Router B1841 4ESW

With dynamic routing, this was working well.

But the 1841 router B is an added hop and a failure concern, when I tried

2821 4ESW (since no new fastethernet ports are available) -- Router A 1841 4ESW| this was a fail.
2821 4ESW (since no new fastethernet ports are available) -- Router B 1841 4ESW| this was a fail.
Router B 1841 4ESW -- Router A 1841 4ESW | this was a success.

This was using the same VLAN setup as described in the OP.  I reckon it has to be the 4ESW module in the 2821 which is the problem. This is a production device and I can't really do anything till a major maintenance is scheduled, but all of my testing points to this single point of failure :)

Marius GunnerudSenior Systems EngineerCommented:
could you provide a network diagram of what you are trying to set up?  

Also could you do a show ip route on the 1841 just to check to see if it has a route to the network.

It might be the 2821 which is the problem but if it is in production and not experiencing any issues at the moment chances are that it is not the issue...but worth checking out none the less.
demon777Author Commented:
No luck with this, we're just using a piggybacked connection, the 4esw on the 2821 will be replaced during next outage.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
demon777Author Commented:
No solution
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.